4

I have installed QGIS (1.8 Lisboa) desktop and server on a Windows XP machine. I am now trying to configure the QGIS Webclient. I downloaded the zip file from GitHUb, and made the changes to the templates, etc. When I open the qgiswebclient.html page the map does not load. The toolbars and other parts of the GUI are all there.

From OSgeo4w Shell I checked my mapserver is running: Mapserver v5.6.6

I copied the qgis-web-client folder into the osgeo4w\Apache\htdocs folder.

Does anyone know which parameters I should check?

  • For me the QGIS Web Client is working fine in Windows7. As the Script Alias changed from /cgi-bin/ "C:\OSGeo4W/bin/ to "C:\OSGeo4W/apps/qgis/bin/" the php is not working now. Server returns the error message as below when typed localhost on address bar. "The requested URL /cgi-bin/php-cgi.exe/index.phtml was not found on this server" I need to add the login controls using php to the application but unfortunately I am stuck now. Please shed some light on this if some one resolved this. – Prajith Mar 15 '15 at 12:07
3

QGIS web client has nothing to do with Mapserver. It is a frontend for QGIS SERVER, so you need to install it with the osgeo4w installer.

The QGIS web client is not made to work on Windows server, so AFAIK there isn't a straightforward procedure to make it work. Anyway I found a way, but it isn't pretty:

  • install QGIS Server and edit https_qgis.conf as described in the wiki.

    QGIS server is then accessible trough

    localhost/qgis/qgis_mapserv.fcgi.exe

  • edit httpd.conf and change

    ScriptAlias /cgi-bin/ "C:\OSGeo4W/bin/"

    to

    ScriptAlias /cgi-bin/ "C:\OSGeo4W/apps/qgis/bin/"

  • removed the ".exe" extension from "qgis_mapserv.fcgi.exe" inside "C:\OSGeo4W/apps/qgis/bin/"

    At this point restart Apache and the server should work with this URL

    localhost/qgis/qgis_mapserv.fcgi

    if yes, you are good to go.

  • This works! QGIS Web Client is running on Windows at last! Runs faster under Linux though if you've got a lot of data. – Rayner Oct 7 '12 at 11:22
2

I had a similar issue.... Im My case, the SRS code was differente in the GlobalOptions.js and my qgis projects....

so, i changed the EPSG variable in globaloptions to a srs code used in qgis project and the maps loaded...

  • Another sugestion... You can try change the EPSG parameter in the URL of the map, setting the qgis project srs code – Kadu Mpires Jul 11 '12 at 13:07
1

Try changing

useGetProjectSettings = true;

to

useGetProjectSettings = false;

in

js/GlobalOptions.js

This solved my issue that no map could be loaded. You need QGIS Server with a verison higher than 1.8 to be able to use this extension.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.