2

I created a network dataset for a county by downloading their shapefile, editing a couple fields, and creating a geodatabase feature class. I'm able to get a route solution if two stops are along the same line but if stops are on different lines I get the error "No route for 'X' for all valid stops. No solution found."

It seems like my turns are not set up correctly. Here is a sample of a segment from the network identify tool. Network Identify Sample

The below also shows I have edges and intersections and no turns. Network Dataset Properties General Tab

I did run the integrated tool and feature to line per some other site recommendations but the network appears to not have any coincident problems. I've also tried changing my connectivity from endpoints to vertices. I set this up very simply with global turns, no elevation, attributes (time, length, oneways), and directions ready. For the time attribute, I changed turn type to 'global turn delay and planned to use the defaults for now until I have time to create my road hierarchy. What have I missed in setting up my network that has resulted in no turns to have been built in?

  • 1. Don't use shapefiles for building a ND; use a file geodatabase feature dataset - it is faster and provides richer support. 2. Go through the Prepare data for use with the Network Analyst extension tutorial - support.esri.com/en/knowledgebase/techarticles/detail/32890. Make it work on the exercise data first. I believe there is something wrong with your connectivity settings, but it is hard to troubleshoot remotely. Take a couple of polylines from your streets feature class and build a simple ND with just a few polylines feature and see if you can solve a route through them. – Alex Tereshenkov Jul 9 '18 at 6:48
  • @AlexTereshenkov Thanks for the feedback. I'll work through that tutorial. – mgc77 Jul 9 '18 at 14:06
0

One of the authors of the source that I was using told me that the shapefile I downloaded is not a routable network. The municipality is working on making it so currently. I was not able to get a great understand of why or what exactly is a routable network. If anyone knows a great explanation of that please comment.

What I ended up doing was installing OSM Toolbox. Because my network was too large to use the "Download, Extract and Symbolize" tool (restriction of 50 units) I had to download the OSM using the overpass api and then used "Load OSM File" from the osm toolbox. From there you don't have to do anything to the loaded osm file (in fact you shouldn't or it might not work) to create a network dataset with the "Create OSM Network Dataset" tool. Worked great for me and would highly recommend!

Some troubleshooting notes:

  • Be sure you're installing the correct extension by checking what version of ArcGIS you have and if it is installed 32bit
  • I had to disable background processing to run the "Create OSM Network Dataset" (go to geoprocessing>geoprocessing options to disable this)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.