2

I am very new to QGIS and GIS itself. I have a shapefile, which was created using Pulkovo 1995/GK zone 9(EPSG:20009) and I want to transform it to new CRS, specifically WGS84(EPSG:4326). So the main question is what is the best way to do so?

I have tried to use the Reprojection Layer feature but the coordinates of my layer doesn't change, even if my CRS changed formally.

For example: I am creating new project and define the project CRS as Pulkovo1995. Then I load the original layer and everything seems OK. In the next step I use Reprojection Layer and my layer disappears until I change the project CRS to WGS84. But the coordinates of the objects remains the same. I cannot see this layer on ESRI maps nor load it into Google Earth. Save As function doesn't help also.

  • When you say that the coordinate of the object didn't change where did you check the coordinate ? – J.R Jul 10 '18 at 11:14
  • In the coordinates window of the status bar. – Yakov Borissenko Jul 10 '18 at 11:23
2

Seems you have hit the wrong Pulkovo zone 9.

You have EPSG:20009

+proj=tmerc +lat_0=0 +lon_0=51 +k=1 +x_0=9500000 +y_0=0 +ellps=krass +towgs84=24.47,-130.89,-81.56,0,0,0.13,-0.22 +units=m +no_defs

while your data uses EPSG:20069

+proj=tmerc +lat_0=0 +lon_0=51 +k=1 +x_0=500000 +y_0=0 +ellps=krass +towgs84=24.47,-130.89,-81.56,0,0,0.13,-0.22 +units=m +no_defs

Note the difference in the false Easting: 20009 puts the zone number in front, while your data and 20069 do not. EPSG:2709 will work too.

Apart from that, the name of your shapefile might suggest to use Pulkovo 1942 zone 9, EPSG:28469.

You have to use Set Layer CRS to set the correct CRS before reprojecting to any other CRS.

  • AndreJ, thank You very much! After I set the correct layer CRS the problem is solved. – Yakov Borissenko Jul 11 '18 at 3:43
0

Reprojecting a layer should work either using the geoprocessing tool ''Reproject layer'' or the ''save as'' method. I think your problem come from the way you check the coordinate and that OTF is not enabled.

So if you use qgis version 2.x make sure that OTF (on the fly CRS transformation) is enabled (in version 3.x OTS is always on).

Then when you check the coordinate of an object be aware that the coordinate in the status bar or the coordinate you get with the Identify tool are the coordinate of the mouse cursor in the data frame, these coordinate are displayed in the project CRS.

To check if your re-projection was successful you could load the two layer (original and re-projected) with OTF on (you could also add a basemap to check that both layer are in the right place). If the two layer superpose your reprojection work well.

  • Thanks for the answer! I tried a few more times in both 2.x (with OTF on) and 3.x versions with "Reprojection Layer" feature and whenever the process is done I cannot see the reprojected layer. When I am saving this and loading into Google Earth it seems like it is pointing out on the dot. Also, I have tried to use reprojection tool with another layer to transform from WGS84 to Pulkovo1995 and it works perfectly. I don't know why it is so bad with vice versa option. And when I use "Save As" function and then try to load the layer into the project it looks like the layer is out of canvas. – Yakov Borissenko Jul 10 '18 at 12:13
  • Are you sure that your original layer is not in another projection ? could you post the extent of the layer, as found in the layer properties, metadata tab? – J.R Jul 10 '18 at 12:18
  • it seem to be a problem with your extend it is not included in EPSG:20009 see here spatialreference.org/ref/epsg/pulkovo-1995-gauss-kruger-zone-9 the – J.R Jul 10 '18 at 12:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.