12

In QGIS 2.18, when I used the Vector > Geoprocessing Tools > Intersection tool, I was able to check an option which said "Ignore NULL geometries [optional]".

Now I've downloaded QGIS 3.2 and that option no longer exists. But when I try to create the intersection between two layers I'm working on, I get a message saying that there is an invalid geometry somewhere and that I should either fix it it or "change the Processing setting to the 'Ignore invalid input features' option."

But that option doesn't exist! Or if it does exist, I just can't find it anywhere.

Does anyone know how/where to change this setting in QGIS 3.2?

19

Go to Settings > Options > Processing and under General change to Ignore features with invalid geometries.

Processing Settings

1

That was a great help @Matthias Kuhn. I had the same problem and tried to solve it by using Geometry Checker plugin. However it takes a lot of time, so if you want a quick solution then you could ignore invalid geometries. For me though, ignoring invalid geometries led to not getting all results so I had to use the "Do not filter(better performance)" choice to get it working.

0

Changing the settings in Qgis 3.0/3.0.2 didn't work for me, but it did with the MMQGIS plugin.

That plugin has been indespendable for me, and way more reliable than what's available with Qgis. And it adds many, many additional features.

Strongly suggest you add the plugin.

.

Process:

MMGIS > Modify > Convert Geometry Type > New Geometry > Lines

protected by Aaron Jun 7 at 2:09

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.