1

My questions is about heatmap plugin in QGIS 3.2.0

I have my data in CRTM05 projection, it´s a metric projection to Costa Rica based in WGS84 Datum.

When I try to run the Heatmap plugin, the running show this:

"Processing algorithm… Algorithm 'Heatmap (Kernel Density Estimation)' starting… Input parameters: { 'DECAY' : 0, 'INPUT' : '/Users/robertovargasmasis/Desktop/Taller SIG 2018 CeU Neily/ejemplo_mapadecalor/puntos_crtm05.shp', 'KERNEL' : 0, 'OUTPUT' : '/var/folders/2z/fsqk6cy931d8r3c97qhc5gcr0000gn/T/processing_5bcc93e95ed54cd8b7e647b933ecf4e1/94fc27fbde38406eabee152a81d702aa/OUTPUT.tif', 'OUTPUT_VALUE' : 0, 'PIXEL_SIZE' : 0.1, 'RADIUS' : 100, 'RADIUS_FIELD' : None, 'WEIGHT_FIELD' : None }

Traceback (most recent call last): File "/Applications/QGIS3.app/Contents/MacOS/../Resources/python/plugins/processing/algs/qgis/Heatmap.py", line 215, in processAlgorithm self.tr('Could not create destination layer')) _core.QgsProcessingException: Could not create destination layer

Execution failed after 0.03 seconds

Loading resulting layers Algorithm 'Heatmap (Kernel Density Estimation)' finished"

Someone have had this problem? How to fix it?

  • I see you have spaces in the path to your input file. Copy the shapefile(s) to a folder with no spaces in its name, to see if that works (maybe something like /Desktop/Taller_SIG_2018....") . Sometimes the filename isn't quoted properly, when that happens , spaces in file paths can break things. – Steven Kay Jul 13 '18 at 21:06
  • I have had the same problem, though I am using SAD6996 projection. The text seems to be the same: Processing algorithm… Algorithm 'Heatmap (Kernel Density Estimation)' starting… Input parameters: { 'DECAY' : 0, 'INPUT' : '/Users/martimfurtado/Dropbox/EQUIPE/Martim/layers/SAD69-96_SHP_TEMA_-_SAUDE_UBS-POSTO_DE_SAUDE-CENTRO_DE_SAUDE.shp', 'KERNEL' : 0, 'OUTPUT' : '/var/folders/wz/0jmtyzqj2bsd_31hv3hkl3vc0000gn/T/processing_21db7899ba1641c081f8cc3781124c73/08461555934740468669e3fb199d4f95/OUTPUT.tif', 'OUTPUT_VALUE' : 0, 'PIXEL_SIZE' : 0.1, 'RADIUS' : 100, 'RADIUS_FIELD' : None, 'WEIGHT_FIELD' : – Martim Ferraz Aug 17 '18 at 15:33
  • This does not really answer the question. If you have a different question, you can ask it by clicking Ask Question. You can also add a bounty to draw more attention to this question once you have enough reputation. - From Review – nmtoken Aug 17 '18 at 16:01
  • I get the same problem, with the same error with QGIS 3.2.3 - "Could not create destination layer" - this is true even if explicit output path with no spaces is supplied. – Konrad Lawson Oct 14 '18 at 14:50
  • I posted a bug report for this: issues.qgis.org/issues/20105 – Konrad Lawson Oct 14 '18 at 15:00
1

Adjust the pixel size. The default value may be too small, thus resulting in an overly large file. The default was 0.1, I changed it to 5 and the heatmap worked.

0

As Damini Jain answered in This post

  1. Right click on your layer.
  2. Select Properties.
  3. In the Properties dialog, switch to the Symbology tab
  4. Select heatmap

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.