I have no raster layers in my map document and no transparencies. Yet the map is rasterized when exported to AI. (Map frame and coordinate grid are vector graphics but everything in the map itself is a single raster image)

I've exported maps to AI before and I did not have this problem. This time the map is quite large (ANSI E @ 34"x44") Perhaps that is the problem?

I know that all layers below a raster layer get rasterized in the output, any transparent layers and layers below a transparent layers. What are the other factors that will cause the AI exported to rasterize all the layers?

  • 1
    Brilliant. The arcpy python code detected a layer I had converted from a KML and within it had a latent tendency to transparency, even though I had 0% transparency, and once I kicked it out and replaced it with a cleaned up copy, perfect! Thanks!
    – user35139
    Jul 28, 2014 at 18:48
  • 1
    Issues with rasterization of vector layers seems to be based on transparent layers as other have said. When I order the layers I want to stay as vector layers in the AI output, above any transparent layers in the table of contents those layers come through in the AI file as vectors, while all other layers are part of the raster image. Thanks for the other posts who helped me figure out this issue. ArcGIS version 10.3
    – user62405
    Nov 15, 2015 at 22:25

7 Answers 7


Jakup: Here's a link to an ESRI page that has links to both the 9x sample and the 10x code: http://support.esri.com/en/knowledgebase/techarticles/detail/29935

9x had a Detect Complex Output sample that could alert one to the presence of a symbol, setting, etc. that was causing rasterization. I can't find a similar sample made for 10x and haven't tried installing it anyway to see if it would work. ESRI offers an arcpy script to do the same supposedly. The script looks odd here so here's the link: http://resources.arcgis.com/en/help/main/10.1/index.html#//00sm00000003000000

import arcpy

def DetectRasterization():
  mxd = arcpy.mapping.MapDocument("CURRENT")
  df_list = arcpy.mapping.ListDataFrames(mxd)
  foundRasterization = False
  noneFoundMsg = "No rasterizing layers were detected."
  for df in df_list:
    lyr_list = arcpy.mapping.ListLayers(mxd, data_frame=df)
    for lyr in lyr_list:
      if lyr.isRasterizingLayer or lyr.supports("BRIGHTNESS"):
        foundRasterization = True
        if lyr.isGroupLayer and lyr.transparency > 0:
          print "In data frame '" + df.name + "', the group layer '" + \
                   lyr.longName + "' is a rasterizing layer:\r",
          print "\tVisibility is " + str(lyr.visible) + ".\n" + \
                "\tTransparency is " + str(lyr.transparency) + " percent.\n"
        elif not lyr.isGroupLayer:
          print "In data frame '" + df.name + "', the layer '" + \
                   lyr.longName + "' is a rasterizing layer:\r",
          if lyr.transparency > 0:
            print "\tVisibility is " + str(lyr.visible) + ".\n" + \
                  "\tTransparency is " + str(lyr.transparency) + " percent.\n"
            print "\tVisibility is " + str(lyr.visible) + ".\n" + \
                  "\tTransparency is 0 percent, but the layer may be a\n" + \
                  "\traster layer or contain rasterizing symbology such\n" + \
                  "\tas bitmap picture symbols.\n"
      del lyr
    del lyr_list
    del df
  if not foundRasterization:
    print noneFoundMsg
  del df_list
  del mxd

  • THanks @John. Sounds what I need to run. WOuld you be able to post the link to the 9x "Detect Complex Output" sample? if it contains source code in VB/VBA I can convert that to a version 10 add-in. Jul 5, 2012 at 14:43
  • The python script works well. Thanks! Now I have a different problem; Illustrator will not open the resulting file. (error; Can't open illustration.) Jul 5, 2012 at 14:59
  • Thanks John, this script worked perfectly on 10.0 as well
    – ChrisHamby
    May 16, 2013 at 16:37

Raster images will also happen in AI if the layers you export are not shapefiles. For instance if you created a layer from selected features and then tried to export this to AI, it would open in AI as a raster image.

To fix this make sure to select data, export data,and save the output feature class as a shapefile.


Try exporting individual layers to ai (or group of layers). This way you can detect which layer is causing the whole map not to be exported as a vector. In doing so, I found out 3D character marker symbols was causing the problem.


I had a similar problem (ArcGIS 10), and couldn't undesrand why. Untill I discovered the following bug:

If a group layer has a sublayer that will be rasterized, it will rasterize the whole group, and all groups below it. Even (the bug) if the group layer is not shown at the current scale (scale dependent visibility).

  • 1
    As a new user please take the Tour. This seems like a comment rather than an answer. You say that it is a bug but my understanding is that this is a known limitation. However, if you have a reference and/or bug number then maybe my recollection is wrong.
    – PolyGeo
    Nov 19, 2015 at 10:09

I found the solution in my case, by not adding % of transparency to layers in arcmap. No matters if there are sublayers.


Yes. Eliminating transparency for any of the overlaying layers helps. Bing imagery added as a basemap is another reason - it creates issues with PDF layering since it adds a transparent "bing" logo on top of everything. No workaround for that one related to Bing imagery.


I have sometimes had this problem when exporting from ArcGIS to Ai - it is normally because I forget to set the export tab to vectorize all the layers rather than rasterise. On the export window that appears go to the bottom of the window and look for the tabs - one of these has the option to set the output to vectorize layers rather than rasterise. Hope this helps anyone with similar problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.