1

After launching Qgis 3.2 Desktop I receive the following error messages:

Impossibile caricare PyQt. Il supporto Python verrà disabilitato.

Traceback (most recent call last): File "", line 1, in ImportError: DLL load failed: Impossibile trovare la procedura specificata.

Versione Python: 3.6.0 (v3.6.0:41df79263a11, Dec 23 2016, 08:06:12) [MSC v.1900 64 bit (AMD64)]

Versione di QGIS: 3.2.0-Bonn 'Bonn', bc43194061

Percorso Python: ['C:/OSGEO4~1/apps/qgis/./python', 'C:/Users/Mascia/AppData/Roaming/QGIS/QGIS3\profiles\default/python', 'C:/Users/Mascia/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins', 'C:/OSGEO4~1/apps/qgis/./python/plugins', 'C:\OSGeo4W64\bin\python36.zip', 'C:\OSGEO4~1\apps\Python36\DLLs', 'C:\OSGEO4~1\apps\Python36\lib', 'C:\OSGeo4W64\bin', 'C:\Users\Mascia\AppData\Roaming\Python\Python36\site-packages', 'C:\OSGEO4~1\apps\Python36', 'C:\OSGEO4~1\apps\Python36\lib\site-packages']

Blockquote

and this

Si è verificato un errore durante l'esecuzione delle istruzioni seguenti: qgis.utils.uninstallErrorHook()

Traceback (most recent call last): File "", line 1, in NameError: name 'qgis' is not defined

Versione Python: 3.6.0 (v3.6.0:41df79263a11, Dec 23 2016, 08:06:12) [MSC v.1900 64 bit (AMD64)]

Versione di QGIS: 3.2.0-Bonn 'Bonn', bc43194061

Percorso Python: ['C:/OSGEO4~1/apps/qgis/./python', 'C:/Users/Mascia/AppData/Roaming/QGIS/QGIS3\profiles\default/python', 'C:/Users/Mascia/AppData/Roaming/QGIS/QGIS3\profiles\default/python/plugins', 'C:/OSGEO4~1/apps/qgis/./python/plugins', 'C:\OSGeo4W64\bin\python36.zip', 'C:\OSGEO4~1\apps\Python36\DLLs', 'C:\OSGEO4~1\apps\Python36\lib', 'C:\OSGeo4W64\bin', 'C:\Users\Mascia\AppData\Roaming\Python\Python36\site-packages', 'C:\OSGEO4~1\apps\Python36', 'C:\OSGEO4~1\apps\Python36\lib\site-packages']

  • the second one looks like this very recent QGIS issue. The first one looks like it's not finding pyqt (or it's finding an old version from 2.18). Try running QGIS without plugins (from osgeo4w shell, run qgis --no-plugins) to see if it's one of your plugins causing the problem. – Steven Kay Jul 14 '18 at 18:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.