I have a tiff raster dataset serving as cost raster, created a start point and destination point serving as feature source data for performing COST PATH in ArcMap 10.4.

Since the tiff raster layer contains no attribute table, I performed INT to get one. However, this new-made attribute table does not contain the value for each pixel.

I have also performed RASTER to POINT to get the value of each pixel. But I cannot join this table to INT attribute table. I am wondering if this is the reason I failed to get a normal result of COST DISTANCE and COST BACKLINK.

Besides, I have already tried performing PATHWAY in IDRISI. But it failed too.


Preformed a LCP before using this YouTube video and model builder I highly suggest checking it out.


  • When I run the model, error 999999, error010045 and error010067 comes up. Pls refer to the new-added image above.
    – Mandy
    Jul 17 '18 at 7:44

I found this youtube video to be really helpful. Follow the steps and it should work with your files: https://www.youtube.com/watch?v=d0Eywj4pIu8

  • Thank you @Racheal. The above result is what I got after I watched this video.
    – Mandy
    Jul 17 '18 at 2:51
  • Thx Mandy. Are you start and finish points two separate files with no other points inside? Jul 17 '18 at 2:55
  • Also, you should not need attribute table - the raster values serve as the cost just fine. Jul 17 '18 at 2:56
  • Yes, the start point and finish point are two separate file with just one point respectively.
    – Mandy
    Jul 17 '18 at 3:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.