1

This is a snapshot of a polygon in arc catalog, in preview mode. Even when brought into ArcMap, it won't display the polygons that are in the white space until you zoom in to an extent of 50,000 or less. I looked and there is nothing in the data frame properties to cause this and the scale range for this polygon is set to show layer at all scales. There aren't any definition queries either that would only display geologic units of certain types. Any clue on how to bring these polygons back from the void? polygon

5
  • 1
    Did you try repairing the geometry? – Kirk Kuykendall Jul 17 '18 at 13:46
  • 1
    Also, it might be a bad index, so try running add spatial index which should rebuild the index. – Kirk Kuykendall Jul 17 '18 at 13:48
  • Tried both of those tools, neither worked. It's now telling me could not load data from the data source. – user2166059 Jul 17 '18 at 19:18
  • What data format is your spatial data? – Aaron Jul 17 '18 at 22:03
  • It's a polygon feature class, within a feature dataset, within a file geodatabase. – user2166059 Jul 18 '18 at 15:18
1

Not an answer really, but the problem is resolved. I had to export the line and polygon feature classes into shapefiles, delete all the polygons, import into a new geodatabase and construct polygons from the line feature class. The original database must have been corrupt.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.