6

Up until QGIS 2.18, all our text placement and rotation values were set to point to the spatial layer table in MSSQL, where we added an ANG (angle) and X, Y field for rotation and placement value storage into our text layer tables.

After installing QGIS 3.2, it seems any label tool we use invokes a prompt to specify a primary key in order to set up fields in the new Auxiliary Storage feature. This has undesirable results as all text is set to zero rotation, except the target label that was rotated.

We do not wish to use this new Auxiliary Storage feature and want to continue using the field values, from the base tables, to store our text placement and rotation data.

Attempting to revert the rotation source to the previous field in our base table causes QGIS 3.2 to crash.

Is there a way to turn off or bypass this new Auxiliary Storage feature?

  • You can still use the data defined properties in your placement panel. Isn't it? – etrimaille Jul 19 '18 at 0:07
  • 1
    I can't reproduce this - can you post more details (or a screencast)? – ndawson Jul 20 '18 at 1:38
  • I documented the process, including screen shots, to a PDF document but don't see a way of providing an attachment in here. – Ed Camden Jul 22 '18 at 22:31
  • 1
    In my experience, if you select a labeling tool that hasn't been assigned to a data field, it will invoke the auxiliary storage feature. Have you assigned the X, Y and rotation values to the fields in your table, using the Labeling Properties window? – Nathan Sep 20 '18 at 17:52
  • Yes, Nathan. As per my first paragraph, we have assigned the X, Y and Rotation values to the base table. It works perfectly in QGIS 2.18 but when running 3.2, it ignores this and overrides these settings, forcing Auxiliary Storage via a pop-up window once text is edited in any way. – Ed Camden Sep 24 '18 at 23:02
2

I had a similar problem in qgis 3.4. My labels weren't showing up. When I looked in Auxiliary Storage under Layer Properties, I found that it was using the wrong field for the label. I blindly hit the Auxiliary Layer button out of frustration, and found I could clear, delete or export the auxiliary storage information. I guessed at delete, and my labels showed up. I don't know what I did exactly, but it worked.

  • had a similar problem, but could not change position after delete. After clearing & choosing the right field it worked. – user16032 Feb 22 at 21:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.