2

I am trying to add the following WMS to QGIS:

https://land.copernicus.eu/pan-european/high-resolution-image-mosaic/very-high-resolution/vhr-2012

It is published by ArcGIS for Server and here is the URL:

https://copernicus.discomap.eea.europa.eu/arcgis/rest/services/GioLand/VeryHighResolution2012/MapServer

Adding it to ArcGIS as an ArcGIS Server or a WMS Server works perfectly fine.

However, I am unable to connect to it in QGIS (2 + 3).

I've tried loading it with the buttons Add WMS/WMTS Layer and Add ArcGIS MapServer Layer, but keep getting the following error:

enter image description here

3

The URL you give is not a WMS URL, despite it working for you in ArcGIS. The WMS URL for the service is at:

https://copernicus.discomap.eea.europa.eu/arcgis/services/GioLand/VeryHighResolution2012/MapServer/WMSServer?

I can load this service URL in QGIS 3 as below:

Copernicus WMS in QGIS 3


So I looked again and it wasn't working for me, and then I realised that when looking at the service initially I had Fiddler (proxy) open to look at the requests being made...

So there does seem to be some issue going on here with using this HTTPS service and QGIS.

I am able to run another HTTPS WMS service (https://inspire.caris.nl/server/services/ows/view/map/unclos-zones-noordzee_IVS?) without the proxy on QGIS so the issue appears to be with the SSL handshake between QGIS and the Copernicus WMS server.

The choice of inspire.caris.nl as a test is not a coincidence, it's because the Caris server is listed in the QGIS > Options > Authentication > Manage Certificates > Servers (Server certificate exceptions) dialog. So it might be worth added the Copernicus certificate here and having a play with the options to see if you can get around the issue.

It's good to know that there is an HTTP alternative that works, but really you'd expect the HTTPS version to work too.

I'm guessing it works for Fiddler as the proxy because FiddlerRoot is regarded as a trusted authority.

  • I tried this as well but it is not working. I am wondering if it is somehow linked to our network; but then again, it works in ArcGIS... I will try from home tonight and check! – BritishSteel Jul 19 '18 at 9:52
  • Maybe you need to add a proxy setting in Qgis that is already set in arc – Ian Turton Jul 19 '18 at 10:54
  • Ahhh, I figured it out! It works using http instead of https – BritishSteel Jul 19 '18 at 11:24
  • Sounds more like a problem in the operating system's certificate store then. – bugmenot123 Jul 20 '18 at 9:11
2

Got it to work by using http instead of https.

So instead of using the URL that you find on the Copernicus website:

https://copernicus.discomap.eea.europa.eu/arcgis/services/GioLand/VeryHighResolution2012/MapServer/WMSServer?

you can also use:

http://copernicus.discomap.eea.europa.eu/arcgis/services/GioLand/VeryHighResolution2012/MapServer/WMSServer?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.