1

I'm stuck with the installation of the PgPointCloud extension for PostgreSQL. I found this article: https://connect.boundlessgeo.com/docs/suite/4.6/dataadmin/pointcloud/install.html

But when I run the following:

apt-get install postgresql-10.4-pointcloud

I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package postgresql-10.4-pointcloud
E: Couldn't find any package by glob 'postgresql-10.4-pointcloud'
E: Couldn't find any package by regex 'postgresql-10.4-pointcloud'

I am using Ubuntu 18.04 [Bionic] and postgreSQL 10.4.

Also, when I type:

 pip3 install glob

I get:

  Collecting glob
  Could not find a version that satisfies the requirement glob (from versions: )
  No matching distribution found for glob

Package regex I installed successfully, but I still get the same error that it can't be found when I try to install pgpointcloud extension.

  • I believe what this is telling you is that you need pacakges 'glob', and 'regex'. – enolan Jul 23 '18 at 20:11
  • The "glob" module is in the standard python library so you can't install a package of it; It's already there. What the error from apt-get is telling you is that it tried finding the package using apt, glob and regex, and it just can't find it ("couldn't find package by glob"). – Trevor J. Smith Jul 23 '18 at 20:31
2

The first clue is that the website documentation you pointed to is specific to PostgreSQL-9.3 and an additional clue is that the date on the bottom of the page suggests it was last modified in 2015. The documentation here is also specific to the OpenGeo Suite toolset, so it's possible that they demand you use their PPAs to install their versions of libraries.

Ubuntu periodically retires/renames packages and just because you've updated your PostgreSQL to a newer version doesn't mean that plugins have followed suit. This is the case with the Ubuntu version of the PostgreSQL PointCloud extension. Checking out the Ubuntu Packages Listing you'll find that a similar plugin is now called libpdal-plugin-pgpointcloud.

You have a few options:

1) Try installing the the Ubuntu library which is part of the PDAL project. They seem to be a newer project that handles pointcloud data calculations. You can install it using:

sudo apt-get install libpdal-plugin-pgpointcloud

Follow the documentation specific for the tool itself and see if you can manage to activate the extension within a database with PGadmin or another database management tool with something resembling the following:

CREATE EXTENSION pointcloud;

2) If you are following the OpenGeoSuite Installation process, you may want to run

sudo apt-get remove libpdal-plugin-pgpointcloud postgresql postgis qgis

to remove any relevant libraries before you start the installation process for their Boundless's OpenGeo Suite. The documentation detailing the installation and usage of their tools can be found here.

  • After running that command, I got, in the end, 0 upgraded, 0 newly installed, 0 to remove and 32 not upgraded. So that caused that I got the error when I tried to make extension: ERROR: could not open extension control file "/usr/share/postgresql/10/extension/pointcloud.control": No such file or directory SQL state: 58P01 – Neven Jul 23 '18 at 21:03
  • Here is imagies of the installition and error in postgres: imgur.com/a/6r8Accx – Neven Jul 23 '18 at 21:08
  • Have you followed the OpenGeoSuite Installation process? This is likely why you weren't able to install the Boundless version of Pointcloud. – Trevor J. Smith Jul 23 '18 at 21:15
  • You may want to run sudo apt-get remove libpdal-plugin-pgpointcloud as well as other PostgreSQL libraries before you start the installation process for Boundless Geo Tools. Alternatively, you could look into what PDAL has to offer. They seem to be a newer project that handles pointcloud data calculations. – Trevor J. Smith Jul 23 '18 at 21:17
  • I installed PDAL within anaconda environment. When I type create extension pointcloud I get an error: ERROR: could not load library "/usr/lib/postgresql/10/lib/pointcloud-1.1.so": /usr/lib/postgresql/10/lib/pointcloud-1.1.so: undefined symbol: Float8GetDatum SQL state: XX000 I don't know why I supposed that I should now ask another question. You can edit your answer about pdal and I will accept it. – Neven Jul 25 '18 at 12:06
1

I installed PDAL in anaconda environment, as Trevor suggested. Installation was successful, in Terminal whatever option that I type was worked, but when I connected with Postgres and tried to create extension pointcloud I was getting an error:

ERROR: could not load library "/usr/lib/postgresql/10/lib/pointcloud-1.1.so": /usr/lib/postgresql/10/lib/pointcloud-1.1.so: undefined symbol: Float8GetDatum SQL state: XX000 

I finally managed to solve my problem, I install pgpointcloud extension again (which is also come weith PDAL). The steps are:

  1. Download zip file from here https://github.com/pgpointcloud/pointcloud
  2. Install Postgres 9.3 (that was my problem, I had 10.4 then 9.6 ..)
  3. Install LibXML2 with sudo apt-get install libxml2
  4. Download and install CUnit from here: http://sourceforge.net/projects/cunit/ You have file there with the install instructions
  5. Navige your terminal to the folder you download from github
  6. Type: ./autogen.sh
  7. ./configure --with-pgconfig=/usr/lib/postgresql/9.3/bin/pg_config
  8. make
  9. sudo make install
  10. make check
  11. sudo make install
  12. PGUSER=a_user PGPASSWORD=a_password PGHOST=localhost make installcheck

Goodluck and if you have the problem with something, feel free to ask me. :)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.