0

I am learning GeoServer by extracting OpenStreetMap shapefile from https://extract.bbbike.org/ and add to Stores n Layers within GeoServer following this tutorial http://docs.geoserver.org/latest/en/user/gettingstarted/shapefile-quickstart/index.html

I can view the Brisbane_Road layers however it has only lines without street names. Notice that the Tiger Road layers (sample came with the installation of GeoServer) is using a style called tiger_roads. I created a new style "Copy from existing style" and choose tiger_roads, and copy the content of Style Editor.

Apply that style to the Brisbane_Road layer and that layer no longer work. What am I doing wrong here, the style part ? Or the layer ? Or the Tiger New York layer was made from a source that support street name or such style?

  • What error message do you see instead of the map? Or in the log file? Most likely issue is a missing attribute – Ian Turton Jul 24 '18 at 18:40
0

I worked it out by creating a new style with the Style Editor xml from Tiger Road, what you need to change in that xml is “NAME” to “name” as this field is named differently (Tiger use “NAME” and OSM use “name”, apply that style to the road layer and Bob is your uncle.

I also did the same with making a style for Railways and the OSM shape can display track or trainline name, platform numbers...

So far so good except for "waterways.shp" the water body was rended as "line" and all waterways have the same width, regardless of main river or creek.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.