3

I have a large polygon vector data set containing approximately 10,000 rows of data. I have used this data to run specific tasks in the QGIS 2 series (many of the Geoprocessing tools) with no issue of invalid geometries.

In QGIS 3 it seems to be picking up many more geometry validity errors even though I am using the exact same data set. I have tried multiple times in both QGIS 3 and 2 on different samples and QGIS 3 can sometimes encounter errors when 2 does not.

I know you can set the parameters to ignore features with invalid geometries but this is leaving me with a lot of errors and blanks in my analysis. Another thing to note is that this is the case in all updates to QGIS 3 up to 3.2.1.

Does anyone know why this might be happening in QGIS 3 and if there is an easy fix?

  • Do you mean as well an error like: polygon is a multipart polygon even if it is not? – Mazu_R Jul 24 '18 at 19:28
3

They aren't more prevalent in 3.x - it's simply that 3.x warns you shoot them, while 2.x happily just overlooks them and accordingly gives outputs which may be wrong or meaningless!

  • I see - thanks for clarifying this. It made me realise how many errors I actually had in my data set... more than I would have liked! – AWGIS Jul 25 '18 at 7:36
3

I'm having similar issues with polygon validity in QGIS 3.2.1, which weren't present in QGIS 2.18. Luckily in my case, simply running the new "fix geometries" tool on the dataset solved the problem, so I would advise trying that, if you didn't already.

Additionally, the "check validity" tool can be used to at least identify the problematic polygons. For large datasets manual correction may be impossible, but at least it can give an idea of the kind of errors present in the data. Keep in mind that the two alternative "method" parameters (QGIS and GEOS) available for the geometry checker may give different results. In my case, for instance, checking with "GEOS" didn't identify the problematic features.

  • Thanks for your answer... the fix geometries tool seemed to work for me too. I just find it strange how this has come about in QGIS 3. – AWGIS Jul 24 '18 at 15:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.