3

I'm having a problem with heat map in QGIS. I have two shapefiles with accidents (with and without victims). Every time I try to create a heatmap with them, it gets pixilated as you can see in the image.

How can I make it smoother and not square, like in this image?

(https://imgur.com/a/PFEBGT8)

I put another picture with the options. QGIS documentation says the number of rows is connected to the number of columns. By doubling one, the other also increases. I noticed, on other maps I made, that the number of columns is greater than the number of rows. In this shapefile the opposite happens. The number of rows is greater than columns. I think that's what affects the outcome, giving this pixelated appearance. I have already tested various radius sizes (10, 30, 50, 1000, 30000 and others), but the result is always almost the same.

I'm using EPSG:4326 (WGS 84)

https://imgur.com/a/JqJ9wJt

  • Have you tried to reduce the X and Y Cell Size in the advanced options? – K_Man Jul 25 '18 at 6:08
  • The ratio of rows/columns is dependent on the ratio of the extent of the source point layer. – ndawson Jul 25 '18 at 7:10
  • If you use 4326, the map unit is "degrees", so your radius of 30 is 30 degrees. Try with much smaller values (0.1 or 0.01) or switch to a projection that use meters. – JGH Jul 25 '18 at 11:35
  • Do you need a heatmap for visualization purposes, or do you need to isolate areas that are 'X values per area' for further analysis? If you just need a visual, I highly recommend checking out the heatmap renderer at the layer level... – DPSSpatial Jul 25 '18 at 15:03
  • @K_Man Yes, I tried to do this but it did not work – Antonio Jul 26 '18 at 23:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.