1

I'm a user of QGis, but this is the first time that I have it installed in a MAC (Sierra 10.12.6). I just installed the new version and I'm trying to install the plugins I usually use. OpenStreetMap gives me the following error:

Couldn't load plugin 'openlayers_plugin' due to an error when calling 
its classFactory() method

I've read that we should move to QuickMapServices, but when I activate that plugin, I have the same error:

Couldn't load plugin 'quick_map_services' due to an error when calling
its classFactory() method 

TypeError: 'QVariant' object is not subscriptable  Traceback (most
recent call last):   File
"/Applications/QGIS3.app/Contents/MacOS/../Resources/pytho/qgis/utils.py",
line 337, in startPlugin 
  plugins[packageName] = package.classFactory(iface)   
File "/Users/delati01/Library/Application
Support/QGIS/QGIS3/profiles/default/python/plugins/quick_map_services/__init__.py",
line 35, in classFactory 
  return QuickMapServices(iface)   File "/Users/delati01/Library/Application
Support/QGIS/QGIS3/profiles/default/python/plugins/quick_map_services/quick_map_services.py",
line 72, in __init__
  self.locale = Locale.get_locale()   File "/Users/delati01/Library/Application
Support/QGIS/QGIS3/profiles/default/python/plugins/quick_map_services/plugin_locale.py",
line 30, in get_locale
  return QSettings().value('locale/userLocale')[0:2] TypeError: 'QVariant' object is not subscriptable


Python version: 3.6.6 (v3.6.6:4cf1f54eb7, Jun 26 2018, 19:50:54) [GCC
4.2.1 Compatible Apple LLVM 6.0 (clang-600.0.57)]  QGIS version: 3.2.0-Bonn Bonn, exported 

Python Path:
/Applications/QGIS3.app/Contents/MacOS/../Resources/python
/Users/delati01/Library/Application Support/QGIS/QGIS3/profiles/default/python
/Users/delati01/Library/Application Support/QGIS/QGIS3/profiles/default/python/plugins
/Applications/QGIS3.app/Contents/MacOS/../Resources/python/plugins
/Library/Frameworks/Python.framework/Versions/3.6/lib/python36.zip
/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6
/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/lib-dynload
/Library/Frameworks/Python.framework/Versions/3.6/lib/python3.6/site-packages
/Users/delati01/Library/Application Support/QGIS/QGIS3/profiles/default/python

Is this a general error because QGIS has just been updated or is it from MacOS X?

  • 3
    There are many plugins for QGIS on all platforms that haven't been updated for QGIS 3 yet (openlayers is still 'experimental' for v3 at this time) ... in the meantime, you could either stick with 2.18 until the final version 3 is out, or add basemaps via methods like this: gis.stackexchange.com/questions/20191/… – DPSSpatial Jul 25 '18 at 15:39
  • Yeah, I've been reading that post, that's how I found out about QuickMapServices, but the basemaps don't load anything. The screen is always white... – Irene Jul 25 '18 at 15:55
  • there are a lot of services in the QuickMapServices plugin that have sources that may or may not be maintained, but I can see the basica OSM Standard service works through QuickMapServices – DPSSpatial Jul 25 '18 at 15:59
  • Same for Windows, QGIS3 and QuickMapServices :-( – Juhele Nov 27 '18 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.