1

Is there a way to force the patch in the legend to include a loosely spaced marker symbol in QGIS print composer?

I'm using a large, loosely spaced marker symbol to represent wetlands in a map I'm producing in QGIS. The symbol looks good in the map, but the legend entry just shows the outline. I would like to make the legend entry include the marker, but can't figure out how to make it happen.

How it looks on the map: enter image description here

And in the legend: enter image description here

I've also run into this issue with line pattern fills.
Is there a way to change either the size of the legend patch or scale the patch to be more representative?

  • 1
    With the legend selected, use the Item Properties panel to set the Symbol width and height... it should expand and show the fill symbol – DPSSpatial Jul 25 '18 at 22:05
  • Another workaround would be to duplicate the wetlands layer with a more closely spaced pattern fill. Turn off the duplicate layer on the map, but use it for the legend. – csk Jul 26 '18 at 17:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.