0

I am trying to implement Pictometry in my Geocortex Essentials viewer. I followed the instructions in the GVH admin guide (I even rolled back my changes and did it twice) and I can't figure out what I am doing wrong.

I believe I am configuring everything in the correct places with the correct syntax. I think there is something wrong with my choice of URLs or API key. The keys and urls were sent to me.

I can open the Linked Maps tool in my viewer, but I get the following error in my console:

PictometryHost is not defined

The pictometry does not load. When I look closer at the error, I see that it says:

var ipa = new PictometryHost('pictometry_ipa', 'http://my.domain.com/ipa/v1/load.php');

Except, of course, it has my actual domain in it. I configured the files to use HTTPS, but the error is showing HTTP - any thoughts?

Specifically in the GVH admin guide I am confused by only one part: It says....

  1. Add an external component for Pictometry to the Integration Module's externalComponents property:
{
  "moduleName": "Integration",
  ...
  "viewModels": [
    {
      ...
      "configuration": {
        ...
        "externalComponents": [
          {
            "id": "pictometry",
            "displayName": "Pictometry",
            "uri": "Resources/3rdPartyMaps/Pictometry.aspx",
            "viewpointIndicatorUri": "Resources/Images/Icons/location-direction-purple-32.png"
          }
        ]
      ...

THEN a little further down in the instructions it says...

Configure the web page's origin:

In one of the viewer's configuration files, add the web page's origin to the Integration Module's allowedOrigins property:

{
   "moduleName": "Integration",
   "moduleType": "geocortex.essentialsHtmlViewer.mapping.modules.integration.IntegrationModule",
   "configuration": {
      "allowedOrigins": ["http://mymaps.mydomain.com"]
   }
   ...

The origin that you configure in the allowedOrigins property must be identical to the URL that you configure in the externalComponent's uri property.

I am confused because my Pictometry.aspx file is hosted on the same domain as my viewer and web page so the relative path works great. However, the actual "Pictometry" page is coming from another website (pol.pictometry.com...).

Do I need to configure "cross domains"?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.