0

I cannot run any GRASS tools from within Python 2.7.15. While the GRASS environment, grass.script etc. are loading correctly and I can run basic checks like

gscript.read_command('g.gisenv')
gscript.read_command('g.mapset', flags='p')

but receiving this error (screenshot) every time I tried to run tools like

gscript.read_command('g.proj', flags='p')
gscript.read_command('g.region', flags='p')

enter image description here

Everything was running smoothly before. If you want to check the startup script that I'm using, please see here). Not duplicating here as already posted earlier. This problem started after I fresh-installed Anaconda 2 with Python 2.7.15 to fix some broken Python libraries.

Already tried fresh installing GRASS 7.4, restarting the machine after each install and uninstall. But not fixing this issue. Need to run the previously working scripts desperately. Any thoughts?

0

This issue was solved by uninstalling xerces-c package and all its dependencies (including GDAL) using conda command line, restarting the machine and reinstalling the xerces-c package with the dependencies.

Absolute pain, no doubt!!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.