2

I'm using ubuntu 18.04 and if I download QGIS 2.18 and I try to run it, I get this:

libpng warning: Application jmp_buf size changed
Segmentation fault (core dumped)

If I try with QGIS 3.2, the error is:

libpng warning: Application was compiled with png.h from libpng-1.6.34
libpng warning: Application  is  running with png.c from libpng-1.2.56
libpng error: Incompatible libpng version in application and library

So it's clear that the problem is with libpng.

I purged libpng-dev and reinstall again but nothing changed.

I tried to purge libpng16-16 but I get:

sudo apt purge libpng16-16
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 libgdk-pixbuf2.0-0 : Depends: libpng16-16 (>= 1.6.2-1) but it is not going to be installed
                      Recommends: libgdk-pixbuf2.0-bin
 libgtk-3-0 : Depends: libcairo-gobject2 (>= 1.10.0) but it is not going to be installed
              Depends: libcairo2 (>= 1.14.0) but it is not going to be installed
              Depends: libfontconfig1 (>= 2.12) but it is not going to be installed
              Depends: libpango-1.0-0 (>= 1.40.5) but it is not going to be installed
              Depends: libpangocairo-1.0-0 (>= 1.40.5) but it is not going to be installed
              Depends: libpangoft2-1.0-0 (>= 1.40.5) but it is not going to be installed
              Depends: adwaita-icon-theme
              Recommends: libgtk-3-bin
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

and then:

~$ sudo apt install libgdk-pixbuf2.0-bin libgtk-3-bin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgdk-pixbuf2.0-bin is already the newest version (2.36.11-2).
libgtk-3-bin is already the newest version (3.22.30-1ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
~$ sudo apt install libgtk-3-0 libgdk-pixbuf2.0-0
Reading package lists... Done
Building dependency tree       
Reading state information... Done
libgdk-pixbuf2.0-0 is already the newest version (2.36.11-2).
libgtk-3-0 is already the newest version (3.22.30-1ubuntu1).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

At this point I'm afraid of breaking something if I continue trying things, so I come here for advice before.

I deleted and reinstalled ubuntu. I installed first thing qgis and it was working. Afterwards I compiled gdal, from source to have it from python as stand alone. It might be this, but I had done this previously without any problems.

1

It also happened to me, and qgis keeps crashing from time to time.

I also compiled gdal library from source to add some drivers.

I was missing libpng-dev package thus while compiling gdal it uses internal libpng instead of system one.

If compiled libgdal does not use libpng (ldd libgdal.* | grep libpng is empty), you have that situation

When compiling gdal, check "./configure | grep png" to double check that it uses preinstalled libpng and not internal one. And you need to clean and recompile gdal again. Now compiled libgdal do use system libpng.

0

I just had this error with another application (Bitrock Installer) and found out via strace that it was a mapping error while accessing /usr/share/fonts/truetype/noto/NotoColorEmoji.ttf

I uninstalled the font apt purge fonts-noto-color-emoji

and the application started.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.