0

I have all the settings right to generate pictures using Atlas, but I can't access the 'Controlled by Atlas' checkmark in the print layout. It's greyed out, and whatever I try I'm unable to change this. I have a shapefile as layer, and an XLS file as Coverage layer. No background. Any idea what I'm doing wrong?

  • Can you post a screenshot of your Atlas panel? – csk Jul 31 '18 at 19:17
  • Which QGIS version are you using? – underdark Jul 31 '18 at 20:02
  • I tried version 2.18, 3.0 and 3.2. Printscreen of the problem: imgur.com/a/1l5I2Ow – Trajan Jul 31 '18 at 21:00
  • Printscreen of the Atlas panel: imgur.com/a/7flmhiG Printscreen of attribute table of the coverage layer: imgur.com/a/PahQz7s – Trajan Jul 31 '18 at 21:06
  • Even when I open QGIS (3.2), start a new project, go straight to new print layout, add a map, the controlled by atlas is greyed out with no option to turn it on. So I'm guessing it has nothing to do with my shapefiles, but it's something else. – Trajan Jul 31 '18 at 21:16
2

In your question you state that you have a XLS file as the coverage layer. I suspect that this means your coverage layer is a table only, without any geometry information.

A geometryless table CAN be used as an atlas coverage layer (e.g. to iterate over text in the rows), but it can't be used to automatically set a map item's extent (since there's no geometry information in that table to set the extent to!). You should still be able to use the data defined scale/x min/x max/etc settings to setup the map's view, if your table has information present which would allow you to derive these values.

  • It looks like you're right. I set a random geometry layer as coverage layer, and then I got to the controlled by atlas! I'll try to find a good coverage layer. Thanks for your help, fixed. – Trajan Aug 1 '18 at 6:42

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.