0

When trying to make the postgis_tiger_geocoder extension and running 'make installcheck' I get the following error:

could not access file "$libdir/postgis-2.4": No such file or directory

Searching for 'postgis-2.4' proves that it does not exist.

I get the same error if I try to install the extensions into a database through the psql interface.

I have seen one ticket with the same problem on this site and the answer was to re-install the software with a different version, but I was hoping there was a more targeted solution. There seem to be so many incompatibilities to overcome that re-installing the software seems likely to solve one problem but then present me with a whole list of other problems.

I have installed postgreSQL 9.6.9 and postGIS 2.4.5.

  • what type of machine are you on? how did you install postgis? – Ian Turton Aug 2 '18 at 15:35
  • Hi Ian, I am on a Centos 7 machine. Postgis was installed by downloading a tar, unzipping it in situ and using the configuration, make and build instructions. – HairLoss Aug 7 '18 at 8:13
  • did you set the libdir variable to point to where ever you installed the postgis libraries? – Ian Turton Aug 7 '18 at 8:21
  • Yes, I tried ./configure --with-pgconfig=/usr/pgsql-9.6/bin/pg_config – HairLoss Aug 7 '18 at 14:16
  • And then later added more declared paths but still the problem persisted. ./configure --with-pgconfig=/usr/pgsql-9.6/bin/pg_config --with-gdalconfig=/usr/bin/gdal-config --with-geosconfig=/usr/bin/geos-config --with-xml2config=/usr/bin/xml2-config --with-libiconv=/usr/bin --with-gui --with-raster – HairLoss Aug 7 '18 at 14:17
1

The solution was a little drastic but it appears to have worked. The available packages and support for Centos appeared limited compared to Ubuntu. I therefore re-purposed the server to run Ubuntu and so far the install appears to have been succesful.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.