0

I had a MapInfo TAB reader and a DWG writer in my workspace. I used line part of DWGStyler transformer to draw lines and polygons in my DWG output file, when I ran my workspace the output schema was correct but FME created lots of blocks for most of the lines and polygon. Is there any way to prevent creating blocks?

enter image description here

2

Because DWG CAD files can't handle the concept of "aggregates" (or multi-part features), we long ago decided to have the writer create blocks when it gets such things, so that they can preserve their original grouping. So for linear features, I'd suggest ensuring you don't have aggregates by Deaggregating (Deaggregator) prior to writing them out.

For area features, there is a setting in the DWG Writers parameters called "Prefer writing donuts as hatches" that you could flip on to cause polygons with holes to be output has hatches. Check out the documentation for this setting at:

https://docs.safe.com/fme/2018.0/html/FME_Desktop_Documentation/FME_ReadersWriters/acad/realdwg_writer.htm

Some other past questions on the FME Community that are related and have some tips (though sadly not complete solutions) can be found at:

https://knowledge.safe.com/questions/50128/shape-to-autocad-no-blocks.html

https://knowledge.safe.com/questions/48916/shapefile-to-dwg-becoming-a-block-and-losing-attri.html

Hope this helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.