I am trying to install Potree on my computer and I am stuck. I am following these instructions:

$ sudo apt-get install python-software-properties git
$ sudo apt-get install build-essential cmake g++
$ sudo apt-get install libboost-all-dev
$ sudo apt-get install cmake-curses-gui
$ sudo apt-get install gcc


$ git clone https://github.com/m-schuetz/LAStools.git
$ cd LAStools/LASzip
$ mkdir build && cd build
$ cmake -DCMAKE_BUILD_TYPE=Release ..
$ make

Potree Converter:

$ git clone https://github.com/potree/PotreeConverter.git
$ cd PotreeConverter
$ mkdir build && cd build  
$ sudo cmake -DCMAKE_BUILD_TYPE=Release -DLASZIP_INCLUDE_DIRS=/home/opengeo/LAStools/LASzip/dll -DLASZIP_LIBRARY=/home/opengeo/LAStools/LASzip/build/src/liblaszip.so ..
**$ sudo make && sudo make install**
$ sudo ln -s ~/LAStools/LASzip/build/src/liblaszip.so /usr/lib
$ PotreeConverter -h

Anyway, I installed LAStools and I have problem with Potree. When I run command:

**$ sudo make && sudo make install**

I get:

Scanning dependencies of target PotreeConverter
 [  8%] Building CXX object 
[ 16%] Building CXX object PotreeConverter/CMakeFiles/PotreeConverter.dir/src/GridCell.cpp.o
[ 25%] Building CXX object 

  fatal error: laszip_api.h: No such file or directory
   #include "laszip_api.h"
   compilation terminated.
   PotreeConverter/CMakeFiles/PotreeConverter.dir/build.make:110: recipe for target 
   'PotreeConverter/CMakeFiles/PotreeConverter.dir/src/LASPointReader.cpp.o' failed
   make[2]: *** [PotreeConverter/CMakeFiles/PotreeConverter.dir/src/LASPointReader.cpp.o] Error 1
CMakeFiles/Makefile2:85: recipe for target 'PotreeConverter/CMakeFiles/PotreeConverter.dir/all' failed
make[1]: *** [PotreeConverter/CMakeFiles/PotreeConverter.dir/all] Error 2
Makefile:129: recipe for target 'all' failed
make: *** [all] Error 2

But I have laszip_api.h in LAStools/LASzip/dll

I tried to manually copy it in /LAStools/LASzip/build/PotreeConverter/build but without success.


There is an issue at the Github Repository that threats the same problem.

The person solved the issue by running the make and make install separated without the && (AND_IF) operator:

sudo make
sudo make install

in the line :

sudo cmake -DCMAKE_BUILD_TYPE=Release -DLASZIP_INCLUDE_DIRS=/home/opengeo/LAStools/LASzip/dll -DLASZIP_LIBRARY=/home/opengeo/LAStools/LASzip/build/src/liblaszip.so ..

Change opengeo to your username

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.