2

I'm new to QGIS and as such I'm pretty hesitant to post anything, but I cannot for the life of me figure out why two raster creation techniques are not working.

For the v.surf.bspline GRASS algorithm: I keep getting 'ERROR: Choose either vector or raster output, not both' as the first error in the log. No matter what I do, skip outputs, change parameters, etc, this happens.

For the SAGA Interpolate(cubic spline) algorithm, I keep getting '###' is not a correct numeric value for option 'K'. 140.0 is the default, but no matter the number, I get this result.

Have people successfully used these algorithms in 3.2 and/or 3.3? I've tried both of these in 3.2 and the 3.3 dev release. Failure. In 2.18.22 the SAGA algorithm works fine, but I can't get any GRASS tool to work, although that's not the point of this post. Here's a LINK to the data I've primarily been using (UDawsThick is the column with values to interpolate), however I have tried both algorithms with other point data, same result.

Apologies if I've missed something obvious. My coding skills are limited and there's every possibility that the answer was staring me in the face and I didn't have the lexicon to understand it. With the limited documentation available for these tools, however, I'm not seeing another option other than appealing to you fine folk.

EDIT: The log for the GRASS algorithm should now be in the link.

1

Congratulations - you've found bugs in 2 QGIS algorithms! The good news is they've both been fixed now, so as soon as 3.2.2 is released these algorithms will work as intended.

0

I tried doing the interpolation right in GRASS, and it seems to work as expected. Here are the commands I ran:

# Start grass, using the shapefile to create a new LOCATION
# and check to make sure the CRS is right:
grass -c work/tmp/U\ Dawson\ WGL\ points.shp udawson
g.proj -p
-PROJ_INFO-------------------------------------------------
name       : NAD_1983_UTM_Zone_13N
datum      : nad83
ellps      : grs80
proj       : utm
zone       : 13
no_defs    : defined
-PROJ_UNITS------------------------------------------------
unit       : Meter
units      : Meters
meters     : 1

# Import the shapefile as a GRASS vector:
v.in.ogr work/tmp/U\ Dawson\ WGL\ points.shp out=udawson

# Make sure to set the computational region to match the vector
# Resolution = 25 meters
g.region -ap vect=udawson res=25

# Run the bspline interpolation (takes a while):
v.surf.bspline input=udawson colu=UDawsThick raster=udawson ew_step=200 ns_step=200

Here's an image of the results: bspline results

I have an idea why it might be failing for you: try to rename the shapefile so that there are no spaces. (You have to renames all the components of the shapefile)

  • Thanks for running this. It's at least something to know that it's just me. I tried changing the names, but no luck. I'll post the log from the results in my question. – internetsareanon Aug 8 '18 at 23:46
  • Seems that it's not "just you". But you have helped improve some open source software. – Micha Aug 9 '18 at 17:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.