1

This question already has an answer here:

  1. I created new project in QGIS (v3.2.1)
  2. Added a OSM Standard layer with QuickMapServices plugin. Current CRS is EPSG:3857

    enter image description here

  3. Now I want to use map in degree units. As far as I understand I need to convert CRS to WGS 84. So I pressed the button:
    enter image description here

  4. Project Properties | CRS dialog box appeared. I filtered CRS by string '84'. There were two potential candidate geographic coordinate systems in that list: EPSG:4326 and IGNF:WGS84G enter image description here

  5. It looks like both of them do not fit because of the map distorted in both cases. The original view (EPSG:3857) was following:
    enter image description here
    After changing to CRS to EPSG:4326 it became look like:
    enter image description here

How to solve my problem with degree coordinate systems?


The following is the image of layer context-menu:
enter image description here
It has not Save as element.

marked as duplicate by user30184, aldo_tapia, Jochen Schwarze, xunilk, Evil Genius Aug 10 '18 at 11:06

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 2
    What do you mean by distorted map? World looks like that when it is presented in "plate carrée" en.wikipedia.org/wiki/Equirectangular_projection – user30184 Aug 9 '18 at 12:07
  • @user30184: Thank you for the question. I added images to explain. – Loom Aug 9 '18 at 12:19
  • 4
    There is nothing wrong. There are different ways to present a round world as flat and each of them is introducing distortion. – user30184 Aug 9 '18 at 12:21
  • If you want to keep the map in EPSG:3857 but to see the coordinates in degrees, change the project setting as in gis.stackexchange.com/questions/131838/…. About the different projections and their distortions see the images en.wikipedia.org/wiki/Map_projection. – user30184 Aug 9 '18 at 12:28
  • Thank you. It helps. Do you mind to make your comment an answer I could upvote? – Loom Aug 9 '18 at 13:06
1

Save your data to a new file and switch CRS to EPSG:4326 when saving. Naturally there will be some distortion, as it is bound to be when you try to press a ball's surface to a plane.

Addition on specified question: Changing the displayed coordinates at the bottom of the screen as follows: ´Project -> project properties -> general (topmost tab) -> displayed coordinates (or similar, third triangle in the tab)´ - at least in QGis 2.18 - maybe in 3.2 it's a bit different, but probably not much.

  • Thank you for the answer. However, I didn't suggested to choose CRS when I saving the data. Did you mean: menu > Project > Save as? – Loom Aug 9 '18 at 12:26
  • Rightclick the layer and choose ´save as´ there. – Erik Aug 9 '18 at 12:36
  • There is not Save as in context menu for layer of my QGIS version (3.2.1). I have added an update with image of my context menu for layer. – Loom Aug 9 '18 at 12:56
  • You cannot "save as" QuickMapServices layers. – HeikkiVesanto Aug 9 '18 at 13:18
  • Didn't see the QuickMap-bit, sorry. Still, when displaying an image in a CRS it wasn't saved with, it will be distorted. Nothing you can do about it. So, do you really have to work using EPSG 4326? – Erik Aug 9 '18 at 13:39

Not the answer you're looking for? Browse other questions tagged or ask your own question.