7

I would like to use the Advanced Digitizing tool and the Move tool to move entire polygons by specified distances and angles. For some reason the "d" (distance), and "a" (angle) fields are grayed out.

Both my project and my layer are in a projected CRS (EPSG:29611).

I would like to do what he does in this video.

How do I get this tool working?

6
  • 1
    They are disabled until you first click on a feature. Do you still see them disabled after starting the move itself?
    – ndawson
    Aug 10, 2018 at 0:04
  • 2
    Which QGIS version? Could you record a screencast showing your attempt?
    – ndawson
    Aug 10, 2018 at 0:22
  • Yes. It was still disabled during the move itself. Sorry, I misunderstood your question yesterday. I am using QGIS 2.18. I will try to get a screencast up later
    – eyerah
    Aug 10, 2018 at 16:28
  • Have you start editing (Menu Layer > Toggle Editing) and select the features you want to move ? Or have you try to make a copy of your layer first? Aug 14, 2018 at 11:29
  • I wanted to try the mentioned features and I realized they were not available in QGIS 2.18.20. I started with Toggle Editing (the icon), then selecting a feature and after it click on Move Feature(s). The message in the advanced Digitizing Panel says "CAD tools are not enabled for the current map tool". I guess current map tool is Move Feature(s). Isn´t it as expected? then it is a bug
    – Marco
    Aug 15, 2018 at 15:46

2 Answers 2

1

I had the same problem whith ESPG:4326... it seems the advanced digitizing tool only works in certain projections. For sure it wont work with geographic projections (as 4326 in my case).

The solution in my case was reprojecting the data to a projected CRS (UTM for example works for sure) and then reproject back to what you need.

-2

(Disabled Advanced digitizing tool problem solved )

I had faced the same problem. I tried changing the Layer CRS. Even though I reinstalled the Qgis, it didn't solve my problem.

This basically happens when your shapefile has Z geometry. Follow these Steps:

  • Save your layer into Shapefile and change its Geometry type From Automatic to Polygon
  • uncheck the include Z dimension

This will solve your problem for sure.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.