1

I would like to compose a large format map for printing in QGIS with the highest detail possible. My process looks like this,

  1. Install "QuickMapServices" plugin
  2. Click the "QuickMapServices" button and choose OSM >> OSM Standard
  3. Pan to my selection area
  4. New print layout (ctrl + p) and make a name
  5. add item >> add map (its now at the zoom where I want more detail displayed and I don't know what to do).
  • If you increase the export resolution, QGIS will export the zoom level of the basemap that gives you that resolution. See this question where the asker is trying to figure out how to stop QGIS from changing the zoom level. – csk Aug 14 '18 at 20:38
3

You must increase either the page size, the export resolution, or both.

To change the page size right-click the layout --> go to Page Properties --> select or define a larger page dimension in the Item Properties panel (screen-right by default).

The export resolution may be changed at the time of (image) export, or within the Layout panel under Export Settings.

QGIS 3.2 (older versions as well) fetches images from a tile server at the time of screen render as well as at export/print. Screen-space tiles are fetched for the layout preview while page-space tiles are fetched at the time of export. Therefor, the layout preview will not reflect the higher-zoom map.

There are upper bounds to the exportable image size and QGIS will warn you if the operation will result in a memory overflow. Additionally, the process of fetching a large number of tiles can take a long time.

Below are the results of an OSM tile map preview and export of an Arch E @ 450dpi.

Map Layout preview image

Map export image

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.