1

I have a raster (created from a polygon layer of sidewalks). The values are 0, 1, and 2. I'm trying to extract a centerline of the sidewalks and I think that ArcScan would be the best method, based on previously asked questions. However, I cannot get the ArcScan toolbar to stop being greyed out. I have the extension turned on, have tried in and out of editor, etc. Does anyone have any idea of what might be the issue? (I've included an image of my workspace, including the files and toolbar). enter image description here

3
  • @reevesii yes, the symbology is already in "unique values" form, and I've tried it in classified as well. No success.
    – Shelby G.
    Aug 15 '18 at 17:02
  • 1
    I think you can only have 2 classes in your raster layer, not 3. Try that. Aug 15 '18 at 18:04
  • 1
    @Mattropolis my friend, you are correct. I went from having a raster with 1 value to a raster with 3, but it turns out 2 classes is the magic number. If you'd like to repost your response as an answer, I'll go ahead and accept it :)
    – Shelby G.
    Aug 15 '18 at 18:26
1

For ArcScan to work you must have a raster layer with only 2 classes in it. It can be a Unique Values renderer or a Classified renderer with only two classes It isn't obvious in the interface, so the toolbar will be greyed out.

From the online help:

Before you can start working with your raster layer in ArcScan, you must ensure that the raster’s layer symbology is displayed as two unique colors. The ArcScan toolbar becomes active once the symbology is changed.

ArcScan supports any two colors so long as they are unique colors with unique color values. You can use the Unique Values rendering option to display the raster as two unique colors or the Classified option to display the raster as two classes.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.