0

I am struggling to produce a terrian file with RAS Mapper.

I have a .tif file produced from a .asc raster elevation and when I tried to add a New Terrain Model as described in the documentation I get the following error:

Error creating Terrain: Input string was not in a correct format.

enter image description here

I have gone through all options related with the file paths and it seems to be something with the file itself, but what?

Among the many ways I have tried to produce it I am using GRASS.

The source of the raster data:

+----------------------------------------------------------------------------+
 | Map:      DTM2plus_2-18882@MA            Date: Mon May 28 12:04:37 2018    |
 | Mapset:   MA                             Login of Creator: MA              |
 | Location: GRASS_SWEREF99_1800                                              |
 | DataBase: R:\6_GIS\62_A_Data\                                              |
 | Title:    DTM2plus_2-18882                                                 |
 | Timestamp: none                                                            |
 |----------------------------------------------------------------------------|
 |                                                                            |
 |   Type of Map:  raster               Number of Categories: 0               |
 |   Data Type:    FCELL                                                      |
 |   Rows:         2500                                                       |
 |   Columns:      2500                                                       |
 |   Total Cells:  6250000                                                    |
 |        Projection: SWEREF99 18 00                                          |
 |            N:    6647500    S:    6642500   Res:     2                     |
 |            E:     185000    W:     180000   Res:     2                     |
 |   Range of data:    min = 8.68  max = 39.2                                 |
 |                                                                            |
 |   Data Description:                                                        |
 |    generated by r.patch                                                    |
 |                                                                            |
 |   Comments:                                                                |
 |    r.patch input="x800_664_18_5025@MA,x800_664_18_5000@MA\                 |
 |    ,x800_664_18_2525@MA,x800_664_18_2500@MA" output="DTM2\                 |
 |    plus_2-18882"                                                           |
 |                                                                            |
 +----------------------------------------------------------------------------+

The command to produce the tif file:

r.out.gdal input=DTM2plus_2-18882@MA output=R:\6_GIS\DTM2plus_2-1882B.tif format=GTiff
  • Try to change the minus '-' in your output raster name to underscore: "_". – Micha Aug 17 '18 at 11:35
0

It was the 32 bits of the image by default that had to be set to 64 bits:

r.out.gdal input=DTM2plus_2-18882@MA output=R:\6_GIS\62_A_Data\DTM2plus_2-1882C.tif format=GTiff type=Float64 nodata=-9999

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.