0

I've tried this a few different ways and can't quite get it to work using QGIS's add WMTS layer tool. The URL loads fine in a browser but won't download as a tile in QGIS. I don't have that good an understanding of how this works/ permissions stuff either - I'm not even sure what it means by capabilities. Any advice?

Full error text:

Failed to download capabilities:
Download of capabilities failed: Error transferring (URL)
-server replied: Not Found

Mapbox URL:https://api.mapbox.com/styles/v1/cdickinson11/cjkwiea7n0raq2rp9gvab9hc4/tiles/256/{level}/{col}/{row}@2x?access_token=pk.eyJ1IjoiY2RpY2tpbnNvbjExIiwiYSI6ImNqY3J6eDlscTBweHMycXMwcWltbnRiN3MifQ.X68p3M-5wwH3AudbxEYdfw

EDIT: Went back and tried to create a link using this guide from mapbox. Still no luck. New error: not a wms server.

New, homemade link:

https://api.mapbox.com/styles/v1/cdickinson11/cjkwiea7n0raq2rp9gvab9hc4.html?fresh=true&title=true&access_token=pk.eyJ1IjoiY2RpY2tpbnNvbjExIiwiYSI6ImNqY3J6eDlscTBweHMycXMwcWltbnRiN3MifQ.X68p3M-5wwH3AudbxEYdfw#0.8/-0.000000/0.000000/0/wmts?access_token=pk.eyJ1IjoiY2RpY2tpbnNvbjExIiwiYSI6ImNqZThwZGg1dDAyMngzM3Fsdmp0dm82YTcifQ.bjVqusaDZqdZVWunQ0xS7A4

  • please provide the url for us to test – Ian Turton Aug 16 '18 at 13:08
0

You can use the WMTS endpoint documented at https://www.mapbox.com/api-documentation/#retrieve-a-maps-wmts-document

  • So, I tried that and this is the message I got back. I'm not too familiar with curl, so perhaps I did something wrong? [1] 26799 [2] 26800 [2]+ Done title=true Coreys-MacBook-Pro:~ coreydickinson$ {"message":"Not Authorized - No Token"} [1]+ Done curl – StupidQuestionGuy Aug 17 '18 at 11:31
  • Fixed it! Realized I was not typing in things in the right place. Just for reference purposes, could you explain how I could have used curl to solve my problem? – StupidQuestionGuy Aug 17 '18 at 12:10
  • 1
    Sounds like you didn't put the URL in quotes. – AndrewHarvey Aug 17 '18 at 22:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.