0

I have a 12 mb KML file that I can easily import into QGIS. The trouble is when I save it as a shapefile the data in the description field, which is html, becomes truncated. Is there a way to avoid this?

  • You have provided so little information that it's hard to help you. This answer might provide a clue, though: gis.stackexchange.com/a/75096/78446 – Jon Aug 17 '18 at 18:51
  • save as a mapinfo tab instead. (will not get truncated data) – Mapperz Aug 17 '18 at 19:09
  • Or as a geopackage, something a bit more standard. – lynxlynxlynx Aug 17 '18 at 19:12
4

Shapefiles have a limit of 254 characters and it's possible that you have more characters than what's allowed in your field description. My suggestion would be to check that first and shorten your description. If that's not an option, one way to work around that is to break your descriptions in to multiple fields and then concatenate (please see this thread).

More information about shapefile character limits here

As Jon mentioned above, more information would be best to help find a solution to your question.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.