1

I'm having issues with saving my grid out to file. Every time I try, I get the error " The output layer could was not generated"

C:\Users\Name\Documents\QGIS\Rav.tif

'Check error log for more information'

I tried the option of save to temporary location but same issue and as you would notice,my path does not contain any whitespace...

I'm using QGIS 3.0 and this was the same issue with 2.2.18 Las Palmas version

I checked this question however QGIS Processing error with SAGA, "output layer could not be open"

Here's the log

Processing algorithm… AlgorithmDialog Input parameters: { 'SHAPES' : 'C:/Users/HP/Documents/QGIS/Ravine/RavSpotH.shp', 'FIELD' : 'ALT', 'SIBSON' : True, 'OUTPUT_EXTENT' : '7.924584,7.933957,5.04092,5.04547 [EPSG:32632]', 'TARGET_USER_SIZE' : 0.0005, 'TARGET_USER_FITS' : 0, 'TARGET_OUT_GRID' : 'C:/Users/HP/Documents/QGIS/Ravine/RavDEM.tif' }

grid_gridding "Natural Neighbour" -TARGET_DEFINITION 0 -SHAPES "C:/Users/HP/Documents/QGIS/Ravine/RavSpotH.shp" -FIELD "ALT" -SIBSON true -TARGET_USER_XMIN 7.924584 -TARGET_USER_XMAX 5.04092 -TARGET_USER_YMIN 7.933957 -TARGET_USER_YMAX 5.04547 -TARGET_USER_SIZE 0.0005 -TARGET_USER_FITS 0 -TARGET_OUT_GRID "C:/Users/HP/Documents/QGIS/Ravine/RavDEM.tif"

C:\PROGRA~1\QGIS3~1.0\bin>set SAGA=C:/PROGRA~1/QGIS3~1.0/apps\saga-ltr

C:\PROGRA~1\QGIS3~1.0\bin>set SAGA_MLB=C:/PROGRA~1/QGIS3~1.0/apps\saga-ltr\modules

C:\PROGRA~1\QGIS3~1.0\bin>PATH=C:\PROGRA~1\QGIS3~1.0\apps\Python36\lib\site-packages\numpy\core;C:\PROGRA~1\QGIS3~1.0\apps\qgis\bin;C:\PROGRA~1\QGIS3~1.0\apps\Python36;C:\PROGRA~1\QGIS3~1.0\apps\Python36\Scripts;C:\PROGRA~1\QGIS3~1.0\apps\qt5\bin;C:\PROGRA~1\QGIS3~1.0\apps\Python27\Scripts;C:\PROGRA~1\QGIS3~1.0\bin;C:\Windows\system32;C:\Windows;C:\Windows\system32\WBem;C:/PROGRA~1/QGIS3~1.0/apps\saga-ltr;C:/PROGRA~1/QGIS3~1.0/apps\saga-ltr\modules

C:\PROGRA~1\QGIS3~1.0\bin>saga_cmd grid_gridding "Natural Neighbour" -TARGET_DEFINITION 0 -SHAPES "C:/Users/HP/Documents/QGIS/Ravine/RavSpotH.shp" -FIELD "ALT" -SIBSON true -TARGET_USER_XMIN 7.924584 -TARGET_USER_XMAX 5.04092 -TARGET_USER_YMIN 7.933957 -TARGET_USER_YMAX 5.04547 -TARGET_USER_SIZE 0.0005 -TARGET_USER_FITS 0 -TARGET_OUT_GRID "C:/Users/HP/Documents/QGIS/Ravine/RavDEM.tif" Unknown option 'SIBSON'


## #####

### ##

# ## ## #### #

##### ## #

# ## ##### #

SAGA Version: 2.3.2 (64 bit)


library path: C:\PROGRA~1\QGIS3~1.0\apps\saga-ltr\modules\ library name: grid_gridding library : Gridding tool : Natural Neighbour author : O.Conrad (c) 2008 processors : 2 [2]


Usage: saga_cmd grid_gridding 3 [-SHAPES ] [-FIELD ] [-TARGET_DEFINITION ] [-TARGET_USER_SIZE ] [-TARGET_USER_XMIN ] [-TARGET_USER_XMAX ] [-TARGET_USER_YMIN ] [-TARGET_USER_YMAX ] [-TARGET_USER_FITS ] [-TARGET_TEMPLATE ] [-TARGET_OUT_GRID ] [-METHOD ] [-WEIGHT ] -SHAPES: Points Shapes (input) -FIELD: Attribute Table field -TARGET_DEFINITION: Target Grid System Choice Available Choices: [0] user defined [1] grid or grid system Default: 0 -TARGET_USER_SIZE: Cellsize Floating point Minimum: 0.000000 Default: 1.000000 -TARGET_USER_XMIN: Left Floating point Default: 0.000000 -TARGET_USER_XMAX: Right Floating point Default: 100.000000 -TARGET_USER_YMIN: Bottom Floating point Default: 0.000000 -TARGET_USER_YMAX: Top Floating point Default: 100.000000 -TARGET_USER_FITS: Fit Choice Available Choices: [0] nodes [1] cells Default: 0 -TARGET_TEMPLATE: Target System Grid (optional input) -TARGET_OUT_GRID: Target Grid Grid (output) -METHOD: Method Choice Available Choices: [0] Linear [1] Sibson [2] Non-Sibsonian Default: 1 -WEIGHT: Minimum Weight Floating point Maximum: 0.000000 Default: 0.000000

C:\PROGRA~1\QGIS3~1.0\bin>exit Execution completed in 20.94 seconds Results: {'TARGET_OUT_GRID': 'C:/Users/HP/Documents/QGIS/Ravine/RavDEM.tif'}

Loading resulting layers The following layers were not correctly generated. C:/Users/HP/Documents/QGIS/Ravine/RavDEM.tif You can check the 'Log Messages Panel' in QGIS main window to find more information about the execution of the algorithm.

  • Could you add full description of the error log? I cannot reproduce this error (using QGIS 3.2.1), unless intentionally giving it a bad data. – Kazuhito Aug 19 '18 at 15:24
  • Have edited the question to include the log – Beveloper Aug 19 '18 at 17:34
  • Thanks! Not sure, but there is a suspicious message Unknown option 'SIBSON' which probably corresponds to -SIBSON true. Is it possible for you to use QGIS 3.2.1? (There is a problem with 3.2.1... it allows only .sdat format as an interim output.) – Kazuhito Aug 19 '18 at 17:44
  • I saw that and unchecked it but still didn't work. Yeah I guess I could try updating to QGIS 3.2.1. Thanks for the help though – Beveloper Aug 19 '18 at 18:57
1

This bug was fixed in QGIS 3.2 - looks like an upgrade is in order!

  • yeah true but I'm not getting the request as that of the tutorial i followed... – Beveloper Aug 25 '18 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.