2

I tried to perform a transaction update, but it failed with this exception message:

    <owsExceptionReport.xsd">
   <ows:Exception exceptionCode="NoApplicableCode"> 
    <ows:ExceptionText>java.lang.RuntimeException: Parsing failed for 
    Point: com.vividsolutions.jts.util.AssertionFailedException
    Parsing failed for Point: 
 com.vividsolutions.jts.util.AssertionFailedException
</ows:ExceptionText>
</ows:Exception>
</ows:ExceptionReport>

Here's the update request sent:

   <wfs:Transaction  
    service="WFS" 
    version="1.1.0"  
    xmlns:topp="http://www.openplans.org/topp" 
  xmlns:SDSDupdate="http://localhost:8080/geoserver/SDSDupdate" 
    xmlns:wfs="http://www.opengis.net/wfs"  
    xmlns:ogc="http://www.opengis.net/ogc"  
    xmlns:gml="http://www.opengis.net/gml"  
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"  
    xsi:schemaLocation="http://www.opengis.net/wfs  
                                            http://schemas.opengis.net/wfs/1.1.0/WFS-transaction.xsd">  
                        <wfs:Update typeName="SDSDupdate:points">  
                          <wfs:Property>  
                            <wfs:Name>the_geom</wfs:Name>  
                            <wfs:Value>  
                              <gml:Point srsDimension="2" srsName="urn:x-ogc:def:crs:EPSG:4326">  
                                <gml:coordinates decimal="." cs="," ts=" ">15.453680224345835, 74.25796508789062</gml:coordinates>  
                              </gml:Point>  
                            </wfs:Value>  
                          </wfs:Property>  
                          <ogc:Filter>  
                            <PropertyIsEqualTo>  
                              <PropertyName>pid</PropertyName>  
                              <Literal>cd607b28-6ac5-85d1-bbb1-c880efbce4d9</Literal>  
                            </PropertyIsEqualTo>  
                          </ogc:Filter>  
                        </wfs:Update>  
                      </wfs:Transaction>

Is it the problem with PostGIS schema or with GML point coordinates being sent?

EDIT: Error performing insert: Error inserting features

   <wfs:Transaction  
    service="WFS" 
    version="1.1.0"  
    xmlns:topp="http://www.openplans.org/topp" 
  xmlns:SDSDupdate="http://localhost:8080/geoserver/SDSDupdate" 
    xmlns:wfs="http://www.opengis.net/wfs"  
    xmlns:ogc="http://www.opengis.net/ogc"  
    xmlns:gml="http://www.opengis.net/gml"  
    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"  
    xsi:schemaLocation="http://www.opengis.net/wfs  
                                            http://schemas.opengis.net/wfs/1.1.0/WFS-transaction.xsd">  
                        <wfs:Update typeName="SDSDupdate:points">  
                          <wfs:Property>  
                            <wfs:Name>the_geom</wfs:Name>  
                            <wfs:Value>  
                              <gml:Point srsDimension="2" srsName="urn:x-ogc:def:crs:EPSG:4326">  
                                <gml:coordinates decimal="." cs="," ts=" ">15.453680224345835, 74.25796508789062</gml:coordinates>  
                              </gml:Point>  
                            </wfs:Value>  
                          </wfs:Property>  
                          <ogc:Filter>  
                            <PropertyIsEqualTo>  
                              <PropertyName>pid</PropertyName>  
                              <Literal>cd607b28-6ac5-85d1-bbb1-c880efbce4d9</Literal>  
                            </PropertyIsEqualTo>  
                          </ogc:Filter>  
                        </wfs:Update>  
                      </wfs:Transaction>

As suggested by NMS here is the new post to the edited part: Geoserver WFST Insert Exception: Error performing insert: Error inserting features

2

It seems to be the problem with GML request your sending.

There should be no white space after the comma, that gives you the Parsing error. Here is the corrected snapshot of your request:

<gml:Point srsDimension="2" srsName="urn:x-ogc:def:crs:EPSG:4326">  
                                <gml:coordinates decimal="." cs="," ts=" ">15.453680224345835,74.25796508789062</gml:coordinates>  
                              </gml:Point> 
  • Well @NMS ur awesome, that right !!! – GeoFresher Aug 20 '18 at 15:07
  • update is working fine. Now I am facing a new issue while inserting: org.geoserver.wfs.WFSException: Error performing insert: Error inserting features – GeoFresher Aug 20 '18 at 15:14
  • @GeoFresher is the error due to the same request as above? – NMS Aug 20 '18 at 15:17
  • 1
    Any logs or request for your error would be better? Not able to figure it out. – NMS Aug 20 '18 at 15:20
  • 1
    @GeoFresher it seems the edited part doesn't support your question, I would suggest you to create a new post based on that error. – GeoFresher Aug 20 '18 at 15:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.