2

I was using the Google maps on OpenLayers plugin in QGIS 2.16.3 successfully before but today when I tried it the page appears as shown in the figure;

enter image description here

I tried re-installing the plugin but this keeps on coming.

Have there been any changes to the plugin?

  • 1
    Google Maps changed their terms of use - this openlayers plugin uses an api key and it is limited after 2,500 uses a day. – Mapperz Aug 20 '18 at 19:56
  • Note: QuickMapServices works still (Tested in QGIS 2.16.3) – Mapperz Aug 20 '18 at 19:57
  • @Mapperz Thanks for your reply. The google maps didn't work from the first time i tried today. Did you mean 2,500 per day for all the users? QuickMapServices does not give the google maps option. I get only, eatlas, landsat, mapsurfer, nasa and OSM. – Shana Aug 20 '18 at 20:07
2

QuickMapServices (version 0.19.9) has the Google Maps Option

This must be a change to the github version

enter image description here

Or upgrade to QGIS 3.2 and use the XYZ tiles Will the OpenLayers Plugin be updated for QGIS3?

  • Thanks @Mapperz. The latest version I installed for QuickMapServices is 0.19.10.1. Looks like unfortunately the Google maps option is dropped. – Shana Aug 20 '18 at 22:26
  • 2
    Google maps does not come preloaded in QMS. Did you install the contributed pack under: Quickmap services settings > more services > get contributed pack? – Baswein Aug 21 '18 at 3:23
  • Installed 'as is' in 2016. – Mapperz Aug 21 '18 at 3:33
  • 1
    Accept the answer then. The whole click on the green button really isn't rocket science, though you seem to be particularly allergic to thanking people for helpling you. – John Powell Aug 21 '18 at 9:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.