2

I have been working on GDAL with windows platform but now I require to shift to linux. I have installed GDAL using

apt-get install gdal-bin libgdal-dev
pip3 install GDAL

Now i require support for GDB file hence , FileGDB driver is required. can anyone help with a walk through to install FileGDB driver in linux ? ogr2ogr --formats doesn't display fileGDB driver.

  • What version is 'gdalinfo --version' ? I always add the "unstable" repos to get something reasonably up to date, might be worth trying 'add-apt-repository ppa:ubuntugis/ubuntugis-unstable'. The driver is called "OpenFileGDB". gdal.org/drv_openfilegdb.html – mdsumner Aug 21 '18 at 13:29
  • I have versions of Linux Mint that are running 2.18 and 3.2 versions of QGIS, and FGDB drivers have come out of the box! – DPSSpatial Aug 21 '18 at 16:32
  • have the same problem here. GDAL 2.2.0 on ubuntu 18.04 – ziggy Aug 22 '18 at 12:30
  • gdalinfo --version gives : GDAL 2.2.3 released 2017/11/20 and I can't use openfilegdb as it has only read permission whereas I require write permission too. – Shashank Vashistha Aug 23 '18 at 5:54
  • Maybe related: gis.stackexchange.com/questions/292506/… – AndreJ Nov 17 '18 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.