1

When I open the metadata in Erdas Imagine 2016 of a raster file (I tried several different raster files) the histogram at the histogram button stays grey. I already tried to change the setting of NAs and select different bands in the multispectral options but no help.

I doubt, there is a problem with Erdas Imagine, as the histograms worked fine on one day when I had access to a computer with Erdas Imagine 2015. Unfortunately, I cannot get access to this computer anymore.

I tried to reach the support team of Erdas (Hexagon Geospatial Support Portal) but was not successful.

Did anyone have a similar problem in Erdas and figured out what the exact problem is? Or has any hints what might have gone wrong?enter image description here

2

You first need to create the stack of your tiff files after that you will have a single image with all the individual spectral Layers registered and stacked into it. The set of tools in Image Metadata allows you to view, edit, and print most of the information of an image file (.img file).

For stacking : Click the Raster Tab in the ribbon and choose spectral. In the spectral drop down menu click on the Layer stack a dialogue box will appear. In the spectral drop down menu click on Layer Stack. Be sure to select TIFF as a file of type. Browse the layer and click Add. Continue this process until all the desired layers are added. Then click the browse option by the output file select the desired location and name it and click OK. The process will run and a single image with all the individual spectral layers would be registered and stacked.

  • Thank you for the answer. But why do I have to stack the layers of the file? When I load in my raster-tiff, it already loads all bands, doesn't it? Just like in ArcGIS oder QGIS? – Li12 Aug 23 '18 at 6:16
  • Yes, it does but to use the histogram feature in erdas imagine you need the .img file because of the set of tools in image metadata where the histogram is allowed to view or edit or print information of an image file. – Damini Jain Aug 23 '18 at 6:18
  • and if it helps/works would you mind upvoting it:)? – Damini Jain Aug 23 '18 at 6:25
  • 1
    Hm ok I could not make it work... Also not with creating a rasterstack-img file... Sorry. But when I used my data on another computer with Erdas Imagine 2015 it worked immediately, also without making a stack out of it... I guess there is something wrong with the installation?... But thanks for your help! – Li12 Aug 23 '18 at 17:13
  • 1
    Maybe you could try the installation again :) maybe some file would be missing or try it out from a different source. – Damini Jain Aug 23 '18 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.