2

enter image description here I am using QGIS 2.18.21. The attribute table of my shapefile has 88 features but after creating the Voronoi, only 86 are in the attribute table and all the points are showing inside the Voronoi diagram.

Please, what could be wrong?

  • Did you use the Count points in polygon (weighted) tool? – Swarley Aug 23 '18 at 13:09
  • Are there coincident points? – Mesa Aug 23 '18 at 13:10
  • I used vonoroi polygon under geometry tools. They actually have the same latitude with another point but a different longitude – user118372 Aug 23 '18 at 13:14
  • 1
    The 3 southern most points shouldn't be in the same polygon, and, just to the right, there is a polygon without point. Either the green points are not the ones used to create the voronoi polygons, or there is a problem during the polygon creation – JGH Aug 23 '18 at 13:30
  • 1
    Hello Havard, i finally downloaded QGIS 3.2.2 and created the voronoi polygon and it worked perfectly and separated the three points that were initially in the same polygon. I actually also have 3.0.0 but it didn`t work also. So I went ahead and downloaded QGIS 3.2.2 and it did. Thank you so much for helping out. – user118372 Aug 28 '18 at 9:23
1

PolyGeo suggested that my comment should be turned into an answer:

There were several bugs in the QGIS Voronoi code. Many were fixed in QGIS 3.2.2 (not backported to QGIS 2.18). According to a comment from user118372 on Aug 28, upgrading to 3.2.2 solved the experienced problems.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.