2

I'm trying without success to calculate a standard deviation image from 4 input images. I already used the r.serie algorithm in 2.18 to calculate an averaged image. Know after upgrading to 3.2.2 on ubuntu 18.04 r.series seems not to work properly. the output is an image with value from 1.79769e+308 to -1.79769e+308.

Any ideas? The log is:

Cleaning up temporary files...

access: No such file or directory

ERROR: LOCATION </home/gobel/newLocation> not available

Starting GRASS GIS...

Executing </tmp/processing_c22010c5e1ed49c0ae5fc8fee008fb9d/grassdata/grass_batch_job.sh> ...

Default region was updated to the new projection, but if you have multiple mapsets `g.region -d` should be run in each to update the region from the default

Projection information updated

Over-riding projection check

Reading band 1 of 1...

r.external complete. Link to raster map <rast_5b7ee239a136610> created.

Over-riding projection check

Reading band 1 of 1...

r.external complete. Link to raster map <rast_5b7ee239a139e11> created.

0..3..6..9..12..15..18..21..24..27..30..33..36..39..42..45..48..51..54..57..60..63..66..69..72..75..78..81..84..87..90..93..96..99..100

Checking GDAL data type and nodata value...

2..5..8..11..14..17..20..23..26..29..32..35..38..41..44..47..50..53..56..59..62..65..68..71..74..77..80..83..86..89..92..95..98..100

Using GDAL data type <Float64>

Input raster map contains cells with NULL-value (no-data). The value -nan will be used to represent no-data values in the input map. You can specify a nodata value with the nodata option.

Exporting raster data to GTiff format...

ERROR 6: SetColorTable() only supported for Byte or UInt16 bands in TIFF format.

2..5..8..11..14..17..20..23..26..29..32..35..38..41..44..47..50..53..56..59..62..65..68..71..74..77..80..83..86..89..92..95..98..100

r.out.gdal complete. File </tmp/processing_c22010c5e1ed49c0ae5fc8fee008fb9d/9331a0aec53041829431d0b6eb7c1af7/output.tif> created.

Execution of </tmp/processing_c22010c5e1ed49c0ae5fc8fee008fb9d/grassdata/grass_batch_job.sh> finished.

Cleaning up temporary files...

Execution completed in 24.22 seconds
Results:
{'output': <QgsProcessingOutputLayerDefinition {'sink':/tmp/processing_c22010c5e1ed49c0ae5fc8fee008fb9d/9331a0aec53041829431d0b6eb7c1af7/output.tif, 'createOptions': {'fileEncoding': 'System'}}>}

Loading resulting layers
Algorithm 'r.series' finished
5
  • Hi did you establish what went wrong here as its a very similar problem to the one I am facing – Sean Jarrett Nov 15 '19 at 13:36
  • Hi @SeanJarrett, I don't remember anymore how I did workaround this. I guess the problem was on how no data were interpreted by each image. Is this happening with you? Which version are you using? I can try to reproduce it again and see what happens, should I? – christian.gobel Nov 19 '19 at 16:44
  • Hi I'm working on QGIS 3.14.3 with GRASS 7.6.1. I want to sum 3 raster layers (not exactly covering the same area. There's an error in the log about SetColorTable() but from other questions it appears this isn't important – Sean Jarrett Nov 22 '19 at 9:57
  • I run a quick test. The SetColorTable() seems to be a common error importing the grass data into Qgis environment. When I tried average two raster with float number, it resulted in an empty raster with a value range from -1.79769e+308 to 1.79769e+308. But with two mask raster ("Eight bit unsigned integer") it works. – christian.gobel Nov 25 '19 at 13:13
  • About the Color Table for not integer data format and the GeoTIFF driver, see: gis.stackexchange.com/questions/101926/…. But for a known issue in the QGIS > 3 implementation of the r.series GRASS algorithm, see: gis.stackexchange.com/questions/342668/…. Not sure about the problem in your question because the log doesn't include the commands and their parameters. – Gabriel De Luca Nov 26 '19 at 23:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.