1

image

I am using QGIS 2.18. I have OSM raster map opened. I go to Vector/OpenStreetMaps/download data. I have tried all three options in the dialog box. My answer is always the same no data downloaded when I try to upload a smaller OSM map and data.dialog box

  • Are you running the latest LTR version QGIS 2.18.23? It might be an issue alredy fixed. – AndreJ Aug 25 '18 at 15:22
  • I'm running 2.18.23, I got the same issue as him yesterday when I did my screenshot – etrimaille Aug 25 '18 at 22:19
  • For some reasons, I still use 2.18.4 with no error. So it might be worth a bug report. Maybe some backporting spoiled it. Note that this feature is dismissed in QGIS 3 in favour of the QuickMapServices plugin. – AndreJ Aug 26 '18 at 6:20
  • QuickMapServices is for rasters. For vectors, you have to use QuickOSM – etrimaille Aug 27 '18 at 15:19
1

How did you load the OSM raster basemap in QGIS? I have always used the OpenLayers Plugin.

When I use that, and load the OSM basemap (without previously having added anything, so in a fresh new project), the map is automatically set to the EPSG:3857, WGS84 / Pseudo Mercator projection.

When I subsesequently open the Download OpenStreetMap data option, the dialog properly shows decimal degrees bounding box parameters (it seems to do an automatic translation from the Web Mercator projection, which of course has totally different coordinates).

I can subequently download data without any issues, I have done that dozens of times.

So, what CRS / projection is listed in your project in the map's properties?

QGIS OpenStreetMap download data dialog

  • Here is where I am at today; downling OSM of my area. Version 2.18.22, Using OpenLayersPlugin/OpenStreetMap CRS EPSG:3857, Project Properties, Settings/CRS/EPSG:3857 – Jerry Applegarth Aug 27 '18 at 12:29
  • Jerry, could you be more clear please? Are you saying that with those settings, you still cannot download data, and still see the errorneous coordinate display? The only difference that I currently see, is that I am still on QGIS 2.18.11. Did something get broken inbetween these versions (instead of fixed as it should be for bugfix releases X.X.n)... – Marco_B Aug 28 '18 at 11:56
0

Indeed, I noticed the bug too.

error message

This is not a "no data" issue as you mentionned in your ticket. It's an error about bad request made to Overpass API.

When you have your dialog:

wrong coordinates

Switch to "manual" and remove extra characters on the right in each box until the "e".

right coordinates

This request will work. Don't use the extent of your layer "OSM Standard", this is covering the whole planet. And unfortunately "From map canvas" is broken because it's using letters in parameters.

  • Your attempt is only halfway correct. The original scrennshot shows a map of Swellendam in South Africa, and the coordinates in the dialogue box are EPSG:3857 meters, not degrees. I have no idea how he got those, I get degrees as expected. – AndreJ Aug 25 '18 at 15:20
  • Ah yes indeed. Only half the solution. Shame on me, I was living in Swellendam. – etrimaille Aug 25 '18 at 22:23
  • I tried to download OSM of my area in Oregon. It came up in degrees. top 43.4482, bottom 42.3668, left -124.783, right -121.77 – Jerry Applegarth Aug 27 '18 at 13:03
  • sorry new to this site, I forgot how to upload pics. to show you my results – Jerry Applegarth Aug 27 '18 at 13:38
  • Thanks and my apology to all who help me through the question I had with downloads of OSM data. I work for a county in Oregon in Search and Rescue. I produce maps for volunteers, maps they are using in searches, rescues, and recoveries. During the fire seasons our people need maps with addresses as the travel door to door doing notifications. Qgis is new to me and I often use it in my work. I have no formal training in mapping and learning as I go. – Jerry Applegarth Aug 29 '18 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.