2

I am trying to change my base map from the open street plug in to Google Street Map from WGS 84 EPSG: 3857 to WGS 84 EPSG: 4326.

My spatialite polygons (originally mapped on United States) projects into the ocean. Is there a way to project the spatialite polygons (mapped in WGS 84 EPSG: 4326 setting) to a the new basemap in WGS 84 EPSG: 4326 setting?

Here is the properties image for reference: enter image description here

  • 1
    Do you really mean "to project the spatialite polygons (mapped in WSG 84 EPSG: 4326 setting) to a the new basemap in WSG 84 EPSG: 4326 setting" - those are both the same coordinate system. – Spacedman Aug 27 '18 at 16:24
  • Hi, Yes I do. My spatialite layer is mapped in EPSG 4326 on a EPSG 3857 base map. This is giving me trouble when I export it into CARTO. The map polygon outlines do not match CARTO's map which is WSG 84 EPSG 4326. – Cynthia W Aug 27 '18 at 17:07
  • What is the extent of the polygon layer, as reported by QGIS with right-click om the layer, properties, metadata tab, properties section? – AndreJ Aug 27 '18 at 17:14
  • Even though you used the base map to assist in mapping your polygons, the polygons themselves are independent of the base layer. You can switch to a different base map and the polygons will remain. – csk Aug 27 '18 at 17:44
  • @AndreJ image updated into question – Cynthia W Aug 27 '18 at 18:15
1

Your spatialite layer looks ok with EPSG:4326 (not sure where you got 144 East, which is outside the US though).

If Carto DB needs coordinates in Web Mercator meters (EPSG:3857), use Save As ... to copy the data into a new spatialite database, with CRS set to EPSG:3857. That way you can work on with your original database, or the new one. Both should be on the same spot in QGIS with OTF enabled.

No need to change the basemap CRS in QGIS, or re-digitize all your polygons.

  • The dataset includes international cities. But the overall solution worked. Thank you! – Cynthia W Aug 27 '18 at 19:34
1

I recomend you to use the Quickmapservices plug-in instead of open layers. You will have access to more online layers (including open street maps) and they project correctly no matter your CRS is. Hope it helps. In case you use Quickmapservices and your layer is still going into the ocean, the issue will be on the real EPSG of the shp.

  • Thank you for your response. I already mapped approx 800 polygons onto the spatialite layer to the google street maps layer. I was hoping for a solution to translating these polygons without losing the shape of the outlines. Thank you though, I will use the quickmapservice for future projects. – Cynthia W Aug 27 '18 at 17:10
0

I am using QGIS 2.18. Go to Raster->Projections->Reproject, put your input source, the output name, check the output source and select the projection that you want.

  • This does not work for tile-based basemaps from the OpenLayers plugin. – AndreJ Aug 28 '18 at 5:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.