This is 4 images (NE, SE, NW, SW) sections of imagery. They have some overlap between them.

  • Working with 1m 3-band orthoimagery.
  • Different parts are sometime flown at different times/sources hence the difference in times of the year.
  • The images are in .tif format.
  • Imagery properties says it's 8 bit pixel Depth and the pixel Type is unsigned integer

enter image description here

When I mosaic them the colours change.

Looks the same as below Number of bands = 3 Mosaic Operator = Last Mosaic Colormap Mode = Last

Looks the same as below Mosaic Operator = Last Mosaic Colormap Mode = Match enter image description here Mosaic Operator = Last Mosaic Colormap Mode = First

This image looks little better, features are better defined. Less Haze to. enter image description here

How can I mosaic these images without it affecting the colour? The brightness of the image has increased..

Is there alternative software to Arcmap that merges raster's better for free?

EDIT Images are 8 Colour bit. Updated better Mosaic image. Still using Raster Mosaic still alters the image colour.

I used the Mosaic to New Raster tool.

Is there a way to remove the black parts?

  • What method did you use to achieve this result? I find that the Raster Mosaic in ArcGIS 10 usually blends colors pretty well.
    – Roy
    Commented Jul 12, 2012 at 19:03
  • Are the images 8 bit (256 colors each)? Or 24 bit?
    – user3461
    Commented Jul 12, 2012 at 19:04
  • What type of imagery are you working with? Source? 1m 3-band orthoimagery? What format? .jp2 .tif .sid? Did you convert these to 8 bit unsigned? These may be important variables in answering your question.
    – Aaron
    Commented Jul 13, 2012 at 2:02
  • Edited Answer to reflect comments. Commented Jul 16, 2012 at 14:00
  • Changing the display properties for background or NoData values might help the black portions. Customize => ArcMap Options => Raster Tab (Raster Layer subtab) This will make these properties the default setting for all .mxds
    – Roy
    Commented Jul 16, 2012 at 14:22

3 Answers 3


I would expect that the change in colour is simply because the colour palette is stretched is over a greater range of values, it shouldn't affect the actual values of the rasters for analysis purposes. But that is just a presumption of what should happen, which doesn't always work with Arc!

From a presentation point of view, why do you want to keep the same colours as the originals, surely this just emphasizes the differences in collection time, or is that the point? If so then simply over lay the images with a transparent nodata value.

As for the black area. Do you simply want it "blank" for presentation or printing purposes? In which case you can change the "no data" display colour to white.


I think it is related not to mosaicing but to raster export in ArcGIS. I have similar change in colors while exporting ortho images in ArcGIS 9.3 (in a new coordinate system for example). Maybe my way to deal with this can be useful for you or someone else.

Just for the current display you can go to the image properties and set the Stretch as Minimum-Maximum instead of the default Standard Deviations. And for removing black areas mark the checkbox Display Background as no color.

enter image description here

Another way if you save the raster as .jpg or like this.

The exported raster has several "satellite" files with the same name, like pyramids, world file, etc. And between them a file rastername.jpg.aux.xml, which contains the raster statistics which help ArcGIS to display the raster. You can open it in the Notepad. There is some information about histograms:

  <SRS>PROJCS[&quot;WGS_1984_UTM_Zone ... </SRS>
    <MDI key="PyramidResamplingType">NEAREST</MDI>
  <PAMRasterBand band="1">
        <HistCounts>13284|2295|637|1469| ... |109|493</HistCounts>
      <MDI key="STATISTICS_MEAN">108.01276699968</MDI>
      <MDI key="STATISTICS_STDDEV">55.175138249326</MDI>
  <PAMRasterBand band="2">

And it results in the ugly change of colors for exported rasters.

I usually open this .xml, delete everything from

<PAMRasterBand band="1">



of the last third band, and save the .xml file. After this the raster is displayed by default in the same colors as the original image. Besides, the original usually doesn't have these statistics in the .xml, or doesn't have .xml at all.


You'll need channel wise histogram matching, then mosaik them channelwise and eventually combine the three mosaiks to the final RGB image.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.