2

Currently I am compiling a web map for an internal platform (15 users) via QGIS2WEB. There is also a WMS service (aerial photograph) integrated, which requires the input of user name and password, as soon as the map is clicked.

However, one problem is that the WMS service does not support "GetFeatureInfo" and therefore error messages appear when clicking with the mouse on the aerial image:

enter image description here

The same error message also appears when requesting information for objects that are also displayed on the map (e.g. construction projects), even if the layer with the aerial photos is deactivated:

enter image description here

Annoyingly, GetFeatureInfo must be activated in the QGIS2WEB dialog. If this is not the case, the query for user name and password is not started and the logon to the WMS server does not start. The aerial photo is therefore not displayed in the first place. Tested it several times already.

Is there any other way to "force" logging on to the WMS service than through a GetFeatureInfo request that causes error messages?

4
  • In addition to the above post. I do not need GetFeatureInfo. Instead, I just need to open a password dialog that asks for username and password. However, this dialog only appears, if GetFeatureInfo is activated and trying to open a pop-up.
    – user127468
    Aug 30, 2018 at 10:21
  • Have you tried changing the qgis2web output format from OpenLayers to Leaflet? Aug 30, 2018 at 14:25
  • Yes I tried this. Did not work.
    – user127468
    Aug 31, 2018 at 12:37
  • You can turn query off for any layer, so GFI shouldn't occur
    – nmtoken
    Aug 31, 2018 at 19:27

1 Answer 1

1

You'll have to edit the code manually after export. It seems that you need to write a custom tileLoadFunction, as per this answer:

https://stackoverflow.com/a/50477911/5613104

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.