0

I have RealTerm terminal emulator connected to my receiver via RS-232 serial, and it is outputing variety of NMEA strings via it's default configuration. Currently, it looks like it is outputing GPGSV,GNGSA,GNGLL,GNRMC,GNVTG,GNGGA, and GLGSV NMEA messages. Here is the data that is output from the receiver on power up.

    $GNTXT,01,01,02,u-blox AG - www.u-blox.com*4E
    $GNTXT,01,01,02,HW UBX-M80xx 00080000*43
    $GNTXT,01,01,02,ROM CORE 2.01 (75331) Oct 29 2013 13:28:17*4A
    $GNTXT,01,01,02,PROTVER 15.00*01
    $GNTXT,01,01,02,GNSS OTP:  GPS GLO, SEL:  GPS GLO*67
    $GNTXT,01,01,02,ANTSUPERV=AC SD PDoS SR*3E
    $GNTXT,01,01,02,ANTSTATUS=DONTKNOW*2D
    $GNTXT,01,01,02,LLC FFFFFFFF-FFFFFFED-FFFFFFFF-FFFFFFFF-FFFFFFF9*4E
    $GNTXT,01,01,02,RF0 dev ok*04

I am trying to change the NMEA output message from the receiver to the "ZDA" message type. Ideally, this is the only message that I would like for the receiver to output. I have tried to get the receiver to output the ZDA message by sending a UBX-CFG-MSG (0x06 0x01). Here is the message in hex.

    0xB5 0x62 0x06 0x01 0x02 0xF0 0x08 0x01 0x10

When this message is sent, there is no response from the receiver (no ACK/NAK), and no change to the message output. Is the UBX-CFG config message the proper way to do this, or can I/should I use the PUBX message. The PUBX message method is not clearly described in the documentation.

What is the proper way to change the NMEA output(s), and why does the receiver not respond (at all) to the request ?

0

OK, I have found a solution to the problem.

I used $PUBX messages to disable/enable all the NMEA sentences that I didn't/did want.

For example, to disable the NMEA "GLL" sentence on all ports, I used the command (in ASCII)

    $PUBX,40,GLL,0,0,0,0,0,0*5C

To enable the NMEA "ZDA" sentence on UART1, I used the command (in ASCII)

    $PUBX,40,ZDA,1,1,0,0,0,0*44

The same message structure was used to enable/disable NMEA sentences on all ports.

I am still interested in knowing why the UBX message didn't work as expected.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.