0

I am having an issue with the arcpy_metadata module. I have a simple shapefile I am trying to load into the MetadataEditor:

import arcpy, os, sys,env 
import arcpy_metadata as md 
myfeatures = "C:/Workspace/Sandbox/MetadataProject/data/model_domains" 
arcpy.env.workspace = myfeatures 
list = arcpy.ListFeatureClasses() 
for item in list: 
    metadata = md.MetadataEditor(item)

When I run this, I get the following error:

TypeError: unhashable type: 'dict'

How can I resolve this?

It also seems that since I am running 64-bit version, that features from a .gdb won't work becuase they require XSLTransform_conversion, which is only supported in 32-bit.

  • 1
    Try adding print(item). Dont name the variable list, it is a function – BERA Aug 30 '18 at 18:40
  • print(item) gives me fluvial.shp, one of the shapefiles in the model_domains directory. – gwydion93 Aug 30 '18 at 19:08
2

The easy answer to this question, after contacting one of the developers on their Github site is that I was using Python 3.6 with ArcGIS Pro and the module is currently only supported in 2.7. Once I switched to my ArcGIS Desktop 10.5 with Python 2.7 environment, it worked.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.