3

I'm trying to place a table in the Layout View for a map that I am making.

However, when I click on Add Table to Layout from the table options, it only adds the column names to the layout... How can I resolve this issue?

Image showing the issue I'm talking about.

My_Issue

  • try selecting the rows you want to include and then add to layout. (just a guess never done this before) – NULL.Dude Aug 30 '18 at 19:42
  • Have you considered adding an Excel spreadsheet (Insert -> Object -> Excel Spreadsheet)? It's more customizable and it looks better on your map. – Gob Tron Aug 31 '18 at 13:09
  • @NULL.Dude I tried that but it is still giving me the same thing – NBE Aug 31 '18 at 13:22
  • @GobTron I tried that as well and the table comes out distorted – NBE Aug 31 '18 at 13:23
2

You need to Extend the height and width of the added table in the layout view, it shows the records according to its size. If you want to adjust the size of the text in the added table in the layout view then go to Attribute table > Table options > Appearance, and modify the properties of the table, then add the table to your layout again.

In addition, you can select all records, then copy selected records and paste it in MS Excel, then copy it from MS Excel and paste it in the layout view(it will be pasted as an image). Doing this you can adjust the size of the table in layout view.

Image below shows how to copy selected records:

enter image description here

  • What exactly do you mean by modify the properties of the table?? Also, the data is an excel spreadsheet so when I right click it, it doesn't say attribute table it just says open – NBE Aug 31 '18 at 13:31
  • 1
    Never mind I figured it out! I just went into excel and formatted it as a table and then copy and pasted it into the layout and it wasn't distorted anymore. Thanks for your help! – NBE Aug 31 '18 at 13:48
2

It seems that the table you are trying to add to the ArcMap layout is coming from an Excel data source.

I tried to reproduce the issue here so I loaded an Excel table into ArcMap then added the table to the layout. I got the same problem you have. I just see the headers without any data in the table.

I got around the problem by exporting the Excel table into a File Geodatabase before adding it to the layout. Doing this solved the problem (though it's probably more like a workaround rather than a solution).

It looks like a bug. For your information, I am using ArcMap 10.4.1.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.