0

I am trying to use the Python API to upload batch files to Google Earth Engine Assets. I have successfully installed the GEE Python api found here.

When I try and execute the upload command in the command prompt I get the following error:

C:\Python27>geebam upload -u walteral@oregonstate.edu --source C:\Users\Alex\Desktop\tombali\001 --dest users/walteral/Tombali/001 --nodata 222

2018-08-31 08:14:20,947 :: oauth2client.transport :: INFO :: Attempting refresh to obtain initial access_token
2018-08-31 08:14:20,950 :: oauth2client.client :: INFO :: Refreshing access_token
2018-08-31 08:14:25,348 :: root :: WARNING :: Collection users/walteral/Tombali/001 already exists
2018-08-31 08:14:26,726 :: root :: INFO :: Processing image 1 out of 12: 
C:\Users\Alex\Desktop\tombali\001\complexity_mat.tif
2018-08-31 08:14:28,301 :: root :: ERROR :: Incorrect credentials. Probably. If you are sure the credentials are OK, refresh the authentication token. If it did not work report a problem. They might have changed something in the Matrix.

I have tried refreshing the token but that hasn't worked. One issue that I had during the install is that pycrypto would not install, instead I used pycryptodome which was recommended here. I don't know if that is part of the problem or not. Is there some way around this credential error so I can upload my files?

1

What you are using is third party software and you may want to contact its author if you are having trouble. To upload an asset with Earth Engine, use the code editor (instructions), or install the python client library and use the command line.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.