2

I have a large dataset compiled of point data. Previously, this data was contained in 3 different files that all were successfully made into layers on QGIS, however I just combined them into one large spreadsheet for ease of operations. I am attempting to load it onto QGIS so I can link a buttload of attribute data and perform further queries. The problem is: QGIS has been grouping my 4th column heading (the very important Y coordinate!) with the first line of data. [What appears in the "create a layer from a delimited text file window]

enter image description here

Here is what my data looks like. Clearly these 2 values are in seperate columns.First 3 rows of csv file

I have tried : -csv, txt and xlsx formats/ all of the different options offered in the window/ adding commas to every cell, adding that as a csv and txt file/ reformatting all cells (number, custom, text)/ adding this data as vector layer, adding as shapefile/ changing column headings.

I'm by no means an expert at GIS but this seems like a silly glitch to get caught up on when everything else had been going so smooth! What am I missing here?

  • 1
    Can you post a sample of your data in plain text form? Maybe there is an issue with carriage returns or delimiters in the merged file? Also sometimes hidden characters can affect the behaviour. – FSimardGIS Aug 31 '18 at 21:53
  • This looks like a delimiter issue. Could you please post the 5 first rows including the header? – MyGIS Sep 4 '18 at 12:40
  • Unq_island unq_trans X Y AD01 AD01E 550000 5762919 AD01 AD01N 549931 5763022 AD01 AD01S 549926 5762792 AD01 AD01W 549856 5762900 AD01 AD01I 549928 5762916 – K.ace Sep 4 '18 at 19:43
1

The problem was finally solved by opening the csv in Rstudio, and writing it to a new csv file there. It looks exactly the same, but now QGIS can read it, and my data points are on my canvas!

0

try using the data as csv-file and generate a special file .csvt describing the fileformat of the csv-file. details can be found here: https://anitagraser.com/2011/03/07/how-to-specify-data-types-of-csv-columns-for-use-in-qgis/

its pretty simple: the following text is copyied from the above page from Anita Grasser:

A .csvt file contains only one line and the types for each column have to be quoted and comma separated, e.g.

"Integer","Real","String"

You can even specify width and precision of each column, e.g.

"Integer(6)","Real(5.5)","String(22)"

read more at: www.gdal.org/ogr/drv_csv.html (End of copy from anita grasser)

  • The first link offers excessive definitions, but doesn't include any steps on how to actually make a .cvst file, and the second link results in a 404. – K.ace Sep 4 '18 at 21:53
  • Use a texteditor to create the cvst File – Kurt Sep 5 '18 at 4:49
  • which OS do you use? you can use your OS standard ascii/ansi - texteditor or any editor of your choice , e.g. under Windows I can recommand notetab. Just dont use a word-processor like Word – Kurt Sep 5 '18 at 15:53
  • I'm on a Mac OS (10.11.6 ). Have been using the text editor however it doesn't have a save-as option. What would you recommend? – K.ace Sep 5 '18 at 18:22
  • sorry, no experience with Mac. But when you save the file as for example myfile.txt I think you can rename it afterwards myfile.csvt in mac finder... – Kurt Sep 5 '18 at 18:42
0

Use Spreadsheet plugin to simply pull data from excel, to have on the go classification / customization of columns data

More info:Creating sectors for telecom towers?

  • Since asking this question I have downloaded the newest version of QGIS along with the associated Python and GDAL. The x,y plug in won't work with this version and the spreadsheet plug in brings up an error message every time I start QGIS. How do I remedy this? – K.ace Sep 5 '18 at 18:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.