3

I am trying to enable PostGIS on a PostgreSQL 10 database on Windows. Earlier it used to work fine, but now I am getting an error 'cache lookup failed for function 1' on enabling the extension.

I am using pgAdmin to do it and have tried shell also. I reinstalled PostGIS from StackBuilder also.

3
  • I'm having the same issue as you yet no solution was found to resolve it. I'm wondering if you did succeed to find it out? Commented Mar 25, 2019 at 9:01
  • no! i just installed postgres again and it works Commented Mar 25, 2019 at 18:25
  • That what I did too Commented Mar 26, 2019 at 7:41

1 Answer 1

1

It is caused by incorrectly configured system settings or irregular entries in the Windows registry.Extensions aren't necessarily supported, the underlying disk files for extensions may have changed.

Try checking that.

I suppose you would have used a big query or something like that.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.