I have an ArcGIS Online account based on my Google account, and I want to publish a service into it via ArcMap.

I first signed in into my account via Google, and then tried to share my map as a service. Yet when I came to the "Choose connection" step, I can't find my account in the list and I'm told to create a new one. I can't understand it, is it maybe an account issue?

What's going wrong?

  • It's not clear from your description which UI elements you have used, but it seems as if you are trying to publish to ArcGIS Server with an Online account.
    – Vince
    Sep 3 '18 at 11:53
  • It seems that you're trying to do this through the ArcMap's UI. If you're indifferent to symbology or minor configuration issues you can publish it through the ArcGIS Online UI\platform.
    – EranGeo
    Sep 3 '18 at 12:14
  • 1
    If you only have a public account it is not possible to publish a hosted service: support.esri.com/en/technical-article/000012093 I publish services to our organizational AGOL account from ArcMap.
    – BERA
    Sep 3 '18 at 12:24
  • 1
    @BERA Yes I opted for a trial version of ArcGIS online and it worked thank you! Sep 3 '18 at 13:09

If you only have a public account it is not possible to publish a hosted service, see:

FAQ: Can a user with a public account publish hosted feature services to ArcGIS Online?


Note that:

Users with public accounts have the option to open a free 30-day trial organizational account subscription if they want to publish hosted services


Users can still upload data to their ArcGIS Online account using their public accounts by exporting the feature classes as a shapefile and zipping it using Windows Explorer. However, only 1,000 features can be uploaded.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.